flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Dahmen <fr...@dahmenia.de>
Subject Re: radiobuttongroup selectedindex problem
Date Tue, 20 Oct 2015 15:40:16 GMT
yes, my problem is solved:
- not set selected on the radiobutton
- in callout on creationcomplete set selectedindex on group

here is a test:

<fx:Declarations>
         <s:RadioButtonGroup id="group0"  />
         <s:Callout id="callout"  >
             <s:HGroup>
                 <s:RadioButton groupName="group0"
                                label="yes"
                                value="0" />
                 <s:RadioButton id="btn1" groupName="group0"
                                label="no"
                                value="1"
                                selected="true"/>
                 <s:Button label="test"
                           click="trace(group0.selectedIndex)" />
             </s:HGroup>
         </s:Callout>
     </fx:Declarations>

     <s:VGroup id="vgroup" width="100%" height="100%">
         <s:Button id="openBtn"
                   label="open"
                   click="callout.open(openBtn)" />
     </s:VGroup>


Very strange: if you place e.g. a Label or other component after 
openBtn, then it works





Am 20.10.2015 um 17:11 schrieb Alex Harui:
>
> On 10/20/15, 12:26 AM, "Frank Dahmen" <frank@dahmenia.de> wrote:
>
>> but if it was the updateDisplayList function, shouldn't the traces then
>> be  different?
> Ah, ok.  I understand better now.  I looked at RadioButtonGroup.as just
> now.  There sure seems to be a lot of code running.  Not sure why.
> Anyway, am I correct that you have solved your problem?
>
>> anyway, the 2nd button is  selected while the groups selectedIndex
>> property is 0
>> isn't this a bug?
> IMO, yes.  If you have a small test case, feel free to file a bug.
>
> -Alex
>


Mime
View raw message