flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kunal Jaura" <kunal.ja...@crmantra.com>
Subject RE: Problem with Modal Popup
Date Mon, 20 Jul 2015 01:30:55 GMT
Hi Alex,

I'm using a Spark list. Funnily this seemed to work perfectly well with Flex 4.6 till 3 months
back. We've had to upgrade to the latest Flex release to support some ANEs and other features
that weren’t working very well with 4.6.

I'll try and come up with a simple test case and see if I can log a defect. Thanks for your
reply thought :-)

Cheers
Kunal Jaura 	     

-----Original Message-----
From: Alex Harui [mailto:aharui@adobe.com] 
Sent: Saturday, July 18, 2015 10:02 PM
To: users@flex.apache.org
Subject: Re: Problem with Modal Popup

Spark or MX List?

Focus management could be messing you up: there are rules for having focusable item renderers.
There could also be an issue with how the visible area gets calculated.

If you have a simple test case, open an issue at http://issues.apache.org/jira/browse/FLEX

-Alex

From: Kunal Jaura <kunal.jaura@crmantra.com<mailto:kunal.jaura@crmantra.com>>
Reply-To: "users@flex.apache.org<mailto:users@flex.apache.org>" <users@flex.apache.org<mailto:users@flex.apache.org>>
Date: Saturday, July 18, 2015 at 10:20 AM
To: "users@flex.apache.org<mailto:users@flex.apache.org>" <users@flex.apache.org<mailto:users@flex.apache.org>>
Subject: Problem with Modal Popup

Hi,

I have a view which shows a form. The form itself is designed as a List with a custom itemRenderer
showing a Name as label and a textinput as the place to enter the value. Some of the fields
in the form are drop down values – list, dates etc. For this I use the PopUpManager to show
a custom component which shows a list spinner or a date picker depending on the type of the
field.

I’m facing a weird problem. As long as I don’t scroll vertically in the list the modal
popup works just fine. I can see the right data and selection works fine as well. But after
I scroll even the slightest bit, the modal popup stops showing. The modal overlay sort of
kicks in but that actual component is not shown. At this point the app becomes unusable and
you have to hard quit and restart the app.

Any idea on why this would be happening? Oh and I’ve tried this with Flex 4.13, 4.14, 4.14.1
and see the same behavior.

Cheers
Kunal Jaura | Director of Architecture | www.CRMantra.com<http://www.crmantra.com/>
 | office +1 (415) 839 9672 | mobile +1 (415) 272 4868 | kunal.jaura@CRMantra.com<mailto:kunal.jaura@CRMantra.com>

[cid:image007.png@01D0C143.62CB13B0]<http://www.crmantra.com/>           [cid:image008.png@01D0C143.62CB13B0]
<https://twitter.com/crmantra>   [cid:image009.png@01D0C143.62CB13B0] <http://www.linkedin.com/company/crmantra>



Mime
View raw message