flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Brunton <fbrun...@lumina.com>
Subject Re: file upload not working on safari and FF on Mac
Date Thu, 04 Jun 2015 10:18:57 GMT
Hi Marcus and Others,

As I was turning this problem into a very simple flex app, I figured out
what the problem was.  The url to upload the file had a query string.  The
query string had some forward and backward slash characters.  On Windows in
IE, FF, and Chrome no problem.  On Chrome on Mac, no problem.  But in
Safari on chrome, problem.  The fix was simply to use the escape(...)
function and the upload works in Safari on ,my Mac.

Thanks for the help!

Fred

On Wed, Jun 3, 2015 at 3:09 PM, Marcus Fritze <marcus.fritze@googlemail.com>
wrote:

> Hi Fred,
>
> You can create a JIRA ticket with attached sample code. So it's better to
> check if it's a bug or only wrong code. :-)
>
> Marcus Fritze
>
> > Am 03.06.2015 um 08:08 schrieb Fred Brunton
> <fredbrunton@yahoo.com.INVALID>:
> >
> > Hi,
> > I have code that uses a FileReference to upload a file.  It's been
> working fine on windows.  And on a Mac it works ok in Chrome.  But it
> doesn't work on Safari on a Mac.  I've got the upload wired up to a
> progress bar and the progress bar doesn't progress at all.
> > Is this a known issue?  Any ideas?
> > I will post some sample code later if this is not a known issue.
> > Cheers,Fred
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message