flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Souza <mario.so...@vizexplorer.com>
Subject Re: Could someone tell me how to upgrade to flexmojos 7.1 please
Date Thu, 26 Mar 2015 00:43:50 GMT
I've just migrated recently our project from flexmojos 3.5 directly to
7.0.1 and it's working perfectly.
Also, we updated the Flex SDK version from 4.5 to 4.14, following the steps
about the mavenizer the sdk and uploading the dependencies to our private
nexus.

And, recently, Chris help me about to build the same artifact/version with
different compiler arguments.. it fits likea glove! :)

My only "issue"  (if that can be considered one) is about the skipTests ...
even running -DskipTests=true, the flexmojos continues compiling/creating
the TestRunner.swf. Doesn't run the TestRunner.swf, but it's still creating.
But, it's a minor issue.


@mariojunior



On 26 March 2015 at 11:01, Christofer Dutz <christofer.dutz@c-ware.de>
wrote:

> Hi,
>
> think I should be quite ideal to help you with this ;-)
>
> Actually from the syntax and configuration options not much has changed.
> The only thing is that the 6.x branch hasn't received quite as much love
> regarding fixing of minor issues ... but hey ... my heart is beating for
> Apache Flex and no longer Adobe Flex ;-)
>
> The major change is that FM 7.x uses the groupId org.apache.flex wherever
> 6.x used com.adobe.flex, but the structure has changed slightly. In general
> switching to FM7.x and updating the groupId should do the trick. On other
> thing that might cause problems are third party libs compiled against Adobe
> flex, these still reference Adobe Flex SDKs with their com.adobe.flex
> groupIds, you will have to detect these with "mvn dependency:tree" and
> exclude them as having both will definitely cause problems.
>
> The Flexmojos testsuite contains a lot of configuration examples:
>
> https://github.com/chrisdutz/flexmojos/tree/flexmojos-7.x/flexmojos-testing/flexmojos-test-harness/projects
>
> I wrote down a lot of stuff in the Flex Wiki:
>
> https://cwiki.apache.org/confluence/display/FLEX/Quick+Start+Guide%3A+Building+Apache+Flex+applications+using+Maven
>
> So if you need any more help ... come back and post your problem. I'll try
> to help you as soon as I can or someone else here on the list will assist.
>
> Good luck,
>    Chris
>
>
> -----Ursprüngliche Nachricht-----
> Von: Gary Yang [mailto:flashflexpro@gmail.com]
> Gesendet: Mittwoch, 25. März 2015 22:33
> An: users@flex.apache.org
> Betreff: Could someone tell me how to upgrade to flexmojos 7.1 please
>
> I am using flexmojos6.0.1,
>
> 1) is there a repository for Flexmojos7.1? do I have to build from source?
> where is the source?
> 2) is there a repository for Apache flex or I have to build byself please?
>
> thanks.
>
> -Gary
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message