flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Brunton <fbrun...@lumina.com>
Subject Re: web service call failures/timeouts
Date Fri, 13 Feb 2015 04:14:02 GMT
@Tomislav - That's a great idea for a workaround to my problem.  If I can't
solve the issue I will try your idea.

@Seth - Your right, I should try sniffing the network traffic for clues.

I got lucky so far, because even though I have seen this faultless web
service failure on several browsers, my client has not been experiencing
it.  So I have a little breathing room to sort this out.  Thanks again!

On Fri, Feb 13, 2015 at 1:04 AM, Seth. <post2seth@gmail.com> wrote:

> You need to trace the call, and server response in case of fault. You can
> use fiddler or firebug for tracking which part of web services is giving
> problem and then optimism accordingly
>
> Regards
> Seth
>
> On Thursday, February 12, 2015, Fred Brunton <fbrunton@lumina.com> wrote:
>
> > Hi,
> >
> > I have a flex app in a browser.  I make Web Service Calls (soap) using
> the
> > code generated by Flash Builder's Data/Services wizard.
> >
> > I have a user that wants to make calls that can take several minutes.  I
> > found in some browsers, the calls worked fine.  In other cases, the call
> > would not work.  When it doesn't work, I do not get a result or fault
> > message callback.  Since my app blocks user inputs during these calls, my
> > app gets hung.
> >
> > I tried on various computers, various flash releases, and various browser
> > (IE, FF and Chrome), and sometimes it works and sometimes not.  I can't
> > even pinpoint where the problem might lie.
> >
> > Any ideas would be greatly appreciated.
> >
> > Cheers,
> > Fred
> >
>
>
> --
> Sent from Gmail iPhone App
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message