flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From akamud <mudd...@gmail.com>
Subject Re: sdk 4.14.0 - flatspark theme font problem
Date Tue, 03 Feb 2015 23:19:58 GMT
> I just download the new sdk. I made some testes. I have a character problem
with new skin "flatspark". Some letters does not shown properly. I think its
because from lato font family (skin's default font family). How can I handle
this problem? Do you have an opinion? 

@ismail, indeed, those characters do not render correctly in Lato. That's
weird, because I know there are chinese developers using this with no
problems. I'll see what we can do with the link you provided us. Thanks!

> Any advice please? 

Can you provide more info on this example? How did you apply the skin?
Did you accept the "Adobe Embedded Font Libraries and Utilites" license?
Which OS are you using?

I'm trying the same example as yours and I'm seeing the icon with no
problems, so I'm trying to get as much information as possible.

> And second: how change style (button states colors) of this FlatSpark
> component?

To change the state colors you can use the Brand property, like this:

<components:ButtonIcon iconFont="{AwesomeUtils.fa_mobile}"
height="{ButtonSizeEnum.Large}" label="Icon Button"
brand="{BrandColorEnum.Inverse}"/>

Check the wiki page to learn more about how to use FlatSpark
https://cwiki.apache.org/confluence/display/FLEX/Using+FlatSpark+skins



--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/sdk-4-14-0-flatspark-theme-font-problem-tp9498p9528.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message