flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Weird bug when an unrelated skin class is present in an RSL (?!?)
Date Fri, 05 Sep 2014 18:16:29 GMT
Hi Nigel,

I'm not asking about application domains, but the URL of the RSL vs the
URL of the main app.  If the actual string of the domain portion of the
URL is different in any way, the RSL could get loaded into a sandbox.

-Alex

On 9/5/14 11:00 AM, "Nigel Magnay" <nigel.magnay@gmail.com> wrote:

>The RSL is loaded into the default app domain (it's a single library in
>flash builder).
>
>It's odd.
>
>There's a totally minimal (I.E: it's got just 2 files) example here:
>https://github.com/magnayn/flexbug
>
>
>
>
>
>On Fri, Sep 5, 2014 at 6:16 PM, Alex Harui <aharui@adobe.com> wrote:
>
>> What is the load order of the RSLs?  You might need to look at generated
>> code to find the order.
>>
>> And just to double-check, "same domain" means full domain:
>>"rsls.foo.com"
>> is a different domain than "www.foo.com" and even the IP address or
>> "localhost" is different than other domain names mapped to the same
>>place.
>>
>> Are you running a debug build with debug code in the RSLs?  No other
>> interesting output in the console?
>>
>> -Alex
>>
>> On 9/5/14 9:36 AM, "Nigel Magnay" <nigel.magnay@gmail.com> wrote:
>>
>> >I am. It does feel like a class isolation issue though.
>> >
>> >
>> >On Fri, Sep 5, 2014 at 5:32 PM, Alex Harui <aharui@adobe.com> wrote:
>> >
>> >> Are you loading the RSL from the same domain as the app?
>> >>
>> >> -Alex
>> >>
>> >> On 9/5/14 4:47 AM, "Nigel Magnay" <nigel.magnay@gmail.com> wrote:
>> >>
>> >> >Even more strangely, I've narrowed it down still more. The mere
>> >>inclusion
>> >> >of this ItemRenderer is sufficient to break the menubar:
>> >> >
>> >> >
>> >>
>> >>
>> 
>>https://github.com/magnayn/flexbug/blob/master/buglib/src/buglib/componen
>> >>t
>> >> >s/skins/MenuCoreItemRenderer2.as
>> >> >
>> >> >If you comment out the use of MenuEvent, it works.
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >On Fri, Sep 5, 2014 at 12:14 PM, Nigel Magnay
>><nigel.magnay@gmail.com>
>> >> >wrote:
>> >> >
>> >> >> So, I've narrowed this down to a test project - see
>> >> >> https://github.com/magnayn/flexbug
>> >> >>
>> >> >> I have a project that uses the "Spark Menubar". It's basically
the
>> >> >>example
>> >> >> given in the documentation:
>> >> >>
>> >> >>
>> https://github.com/magnayn/flexbug/blob/master/buglet/src/buglet.mxml
>> >> >>
>> >> >> This all works fine, in isolation. However. If the project
>>includes
>> >> >> 'buglib' as an RSL, the menu stops working.
>> >> >>
>> >> >> buglib contains only 1 file, which is a skin:
>> >> >>
>> >> >>
>> >> >>
>> >> >>
>> >>
>> >>
>> 
>>https://github.com/magnayn/flexbug/blob/master/buglib/src/buglib/componen
>> >> >>ts/skins/TestSkin.mxml
>> >> >>
>> >> >> The skin does not mark in metadata the HostComponent (which would
>>be
>> >>a
>> >> >> spark list). The skin is not referenced *anywhere *from the MXML.
>> >> >>
>> >> >> If the library is included instead as 'merged into code',
>>everything
>> >>is
>> >> >> fine (even if the skin is referenced, to prevent it being
>>stripped).
>> >> >>
>> >> >> And, here's where it gets even weirder :
>> >> >> If you remove the statement
>> >> >>
>> >> >> itemRenderer="spark.components.itemRenderers.MenuBarItemRenderer"
>> >> >>
>> >> >> From the TestSkin.mxml (*even though it is not being used
>>anywhere in
>> >> >>the
>> >> >> project*), it all works fine again!
>> >> >>
>> >> >>
>> >> >> Ideas? Have I just missed something?
>> >> >>
>> >> >>
>> >> >>
>> >> >>
>> >> >>
>> >> >>
>> >>
>> >>
>>
>>


Mime
View raw message