flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jude <flexcapaci...@gmail.com>
Subject Re: Which Internet Explorer version is required by each FlashPlayer version?
Date Tue, 30 Sep 2014 17:51:29 GMT
Flash has typically not had a required browser version or it's been very
low. Since it's a plugin it runs in it's own sand box so to speak. The only
requirements I would think would be if a Flash Player version required
specific API's of the NPAPI and PPAPI plugin formats.

Just recently Flash Player has added support for browser zoom, (Improved
Resolution of Stage3D Content on Browser Zoom). This is the first time I've
seen FP require a newer browser in as long as I can remember. However it's
not required to have this browser it's only required if you need this
feature.

>From the Adobe FP blog:

As of FP 15, the above feature is only available for Internet Explorer on
Windows 8.x.  Feature availability on other browsers and OSes is currently
being investigated.  Browsers based the NPAPI plug-in (eg, Firefox, Safari)
will not support this feature due to lack of plug-in APIs for retrieving
the browser zoom value.  Support for browsers based on the PPAPI plug-in
(eg, Chrome) is being considered for a near future version of FP. On
browser platforms that do not support this feature, the
Event.BROWSER_ZOOM_CHANGE event will not fire, the return value of
Stage.browserZoomFactor will not change, and setting of the
wantsBestResolutionOnBrowserZoom parameter will have no effect. [1]

[1]
http://blogs.adobe.com/flashplayer/2014/09/improved-resolution-of-stage3d-content-on-browser-zoom.html#more-6562

On Tue, Sep 30, 2014 at 11:20 AM, DarrenEvans <
darren.evans@allocatesoftware.com> wrote:

> So for prosperity and incase anyone else needs this information.....
>
> After a bit of VM jiggery pokery and some looking back through archived
> Adobe pages. I'm assuming Adobe just dropped support for IE7 at either
> FlashPlayer 13 (maybe 12, as I couldn't find an archive of the requirements
> page for 12).
>
> However, having set up an XP/IE7 environment and installing 11.7,
> 12.0.0.77,
> 13.0.0.244, 14.0.0.176, 15.0.0.167 sequentially expecting a failure at some
> point I can report that all versions work with IE7!
>
>
> Alex Harui wrote
> > Don't know for sure.  You could try filing a bug at bugbase.adobe.com
> > about the release notes.
> >
> > HTH,
> > -Alex
>
>
>
>
>
> --
> View this message in context:
> http://apache-flex-users.2333346.n4.nabble.com/Which-Internet-Explorer-version-is-required-by-each-FlashPlayer-version-tp8165p8224.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message