flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: Proper commandline arguments
Date Fri, 05 Sep 2014 14:50:39 GMT
Geee ... my mail client re-formatted the urls :-( just immagine the "<.....>" part didn't
exist :)

Chris
________________________________________
Von: Christofer Dutz <christofer.dutz@c-ware.de>
Gesendet: Freitag, 5. September 2014 16:41
An: users@flex.apache.org
Betreff: Proper commandline arguments

Hi,


I'm currently working on fixing a bug in Flexmojos which caused to produce an ambiguous argument
list when using multiple namespaces.

Currently Flexmojos used to produce:


-compiler.namespaces.namespace <http://www.adobe.com/2006/mxml> http://www.adobe.com/2006/mxml
mx-manifest.xml -compiler.namespaces.namespace library://ns.adobe.com/flex/spark spark-manifest.xml

But want to change that to the alternate "=" and "," notation the error message suggests.
So would I convert this to:

-compiler.namespaces.namespace=<http://www.adobe.com/2006/mxml>http://www.adobe.com/2006/mxml,mx-manifest.xml
-compiler.namespaces.namespace=library://ns.adobe.com/flex/spark,spark-manifest.xml

or would it become:

-compiler.namespaces.namespace=<http://www.adobe.com/2006/mxml>http://www.adobe.com/2006/mxml,mx-manifest.xml
-compiler.namespaces.namespace+=library://ns.adobe.com/flex/spark,spark-manifest.xml

?So the first namespace would have an "=" and each following one would be a "+="?
I sort of couldn't find the spec for this.


Chris



Mime
View raw message