flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From storo84 <sebastiantor...@gmail.com>
Subject Re: Workaround to solve faulty verbose-stacktraces=true compiler parameter
Date Fri, 22 Aug 2014 15:08:54 GMT
Alex, 

The question is on the release version of the application, not on the
emulator since the flag -verbose-stacktraces=true is meant to be used on the
release version and not on the debug version of the app, since on the later
you use debug=true.

I created a very simple desktop app to test if it works and found the same
error. Here's the code:

<?xml version="1.0" encoding="utf-8"?>
<s:WindowedApplication xmlns:fx="http://ns.adobe.com/mxml/2009" 
					   xmlns:s="library://ns.adobe.com/flex/spark" 
					   xmlns:mx="library://ns.adobe.com/flex/mx"
					   applicationComplete="applicationCompleteHandler(event)">
	<fx:Script>
		
	</fx:Script>
	
	<s:TextArea id="text" top="0" width="100%"/>
	
	<s:Button label="Generate Error"
			  click="this['foo'].holi = 'hola'" 
			  bottom="0" width="100%"/>
	
</s:WindowedApplication>

Here are the compiler parameters: *-locale en_US -swf-version=25
-verbose-stacktraces=true -debug=false*

Next is an image of the results:

<http://apache-flex-users.2333346.n4.nabble.com/file/n7714/actual_results.png> 

The next image is what you get on the emulator:

<http://apache-flex-users.2333346.n4.nabble.com/file/n7714/expected_results.png> 

This is why I asked Frédéric about what did he do since I'm clearly not
getting the same results. Frédéric, did you use the emulator for your test
or you used a release version of the application?

I'll be expecting your comments on the results.



--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Workaround-to-solve-faulty-verbose-stacktraces-true-compiler-parameter-tp7685p7714.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message