flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: Flexmojos 7.0.0 not working with 4.13.0.20140701
Date Tue, 29 Jul 2014 08:54:28 GMT
I am working hard on making this possible. This is ha huge task, but we are working on it.

Currently we are still verifying the current solution works correctly. I guess you can espect
it to hapen some time this year.

Chris

________________________________________
Von: Gary Yang <flashflexpro@gmail.com>
Gesendet: Montag, 28. Juli 2014 17:53
An: users@flex.apache.org
Betreff: Re: Flexmojos 7.0.0 not working with 4.13.0.20140701

thanks Chris, is there a public Maven repository that serves Apache Flex so
that I don't need to mavenize it in Apache packages again?

-Gary


On Mon, Jul 28, 2014 at 10:24 AM, Christofer Dutz <christofer.dutz@c-ware.de
> wrote:

> Ok ... so the problem is that FM 6.x uses the groupId "com.adobe.flex" for
> compiler and framework. FM 7.x uses "org.apache.flex"
> So when using FM6 you are overriding the compiler version with 4.13, but
> when using FM7 you are using the default import FM was built against which
> was 4.12.
>
> When switching to FM7 you need the compiler artifact:
>
>                     <dependency>
>                         <groupId>org.apache.flex</groupId>
>                         <artifactId>compiler</artifactId>
>                         <version>${flex.sdk.version}</version>
>                         <type>pom</type>
>                     </dependency>
>
> and the framework artifact:
>
>         <dependency>
>             <groupId>org.apache.flex.framework</groupId>
>             <artifactId>flex-framework</artifactId>
>             <version>${flex.sdk.version}</version>
>             <type>pom</type>
>         </dependency>
>
> But if you are using FM7.1.0-SNAPSHOT and the mavenizer from the
> mavenizer-refactoring branch, this will however be:
>
>         <dependency>
>             <groupId>com.adobe.flex</groupId>
>             <artifactId>framework</artifactId>
>             <version>${flex.sdk.version}</version>
>             <type>pom</type>
>         </dependency>
>
>
> Chris
>
> ________________________________________
> Von: Gary Yang <flashflexpro@gmail.com>
> Gesendet: Montag, 28. Juli 2014 16:15
> An: users@flex.apache.org
> Betreff: Re: Flexmojos 7.0.0 not working with 4.13.0.20140701
>
> Chris,
>
> thanks for reply, I will definitely look into the Mavenizer.
>
> It seems Flexmojos7.0.0 depend on Flex 4.12.0.20140303:
>
> http://maven-repository.com/artifact/net.flexmojos.oss/flexmojos-flex-compiler/7.0.0
>
>
> Please take a look at the pom i am using:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
>          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>     <modelVersion>4.0.0</modelVersion>
>
>     <groupId>com.flashflexpro</groupId>
>     <artifactId>aflash</artifactId>
>     <version>0.1-SNAPSHOT</version>
>     <packaging>swf</packaging>
>
>     <properties>
>         <target.flash.player.version>14.0.0</target.flash.player.version>
>         <flexmojo.version>7.0.0</flexmojo.version>
>         <flex.sdk.version>4.13.0.20140701</flex.sdk.version>
>     </properties>
>
>     <build>
>         <sourceDirectory>src/main/flex</sourceDirectory>
>         <directory>../.mvn.build/${project.build.finalName}</directory>
>         <plugins>
>             <plugin>
>                 <groupId>net.flexmojos.oss</groupId>
>                 <artifactId>flexmojos-maven-plugin</artifactId>
>                 <version>${flexmojo.version}</version>
>                 <extensions>true</extensions>
>                 <configuration>
>
> <actionscriptFileEncoding>UTF-8</actionscriptFileEncoding>
>                     <localesCompiled>
>                         <locale>en_US</locale>
>                     </localesCompiled>
>
>
>
> <flashPlayerCommand>${test.flashplayercommand}</flashPlayerCommand>
>                     <storepass/>
>
> <targetPlayer>${target.flash.player.version}</targetPlayer>
>                     <debug>${output.debuggable.swf}</debug>
>                     <defines>
>                         <property>
>                             <name>CONFIG::debugging</name>
>
> <value>${conditional.compile.config.debugging}</value>
>                         </property>
>                         <property>
>                             <name>CONFIG::production</name>
>
> <value>${conditional.compile.config.production}</value>
>                         </property>
>                     </defines>
>
>                     <keepAs3Metadatas>
>                         <keepAs3Metadata>RemoteClass</keepAs3Metadata>
>                     </keepAs3Metadatas>
>
>                 </configuration>
>
>                 <dependencies>
>                     <dependency>
>                         <groupId>com.adobe.flex</groupId>
>                         <artifactId>compiler</artifactId>
>                         <version>${flex.sdk.version}</version>
>                         <type>pom</type>
>                     </dependency>
>                 </dependencies>
>             </plugin>
>         </plugins>
>     </build>
>     <dependencies>
>         <dependency>
>             <groupId>com.adobe.flex.framework</groupId>
>             <artifactId>flex-framework</artifactId>
>             <version>${flex.sdk.version}</version>
>             <type>pom</type>
>         </dependency>
>
>         <dependency>
>             <groupId>com.adobe.flexunit</groupId>
>             <artifactId>flexunit</artifactId>
>             <version>4.0-rc-1</version>
>             <type>swc</type>
>             <scope>test</scope>
>         </dependency>
>
>     </dependencies>
>
> </project>
>
> thanks again.
>
> -Gary
>
>
> On Mon, Jul 28, 2014 at 2:01 AM, Christofer Dutz <
> christofer.dutz@c-ware.de>
> wrote:
>
> > Treating from the error message, it seems you are using the framework in
> > version 4.13, but the compiler in 4.12 so the error message is valid.
> Could
> > you post your pom, and I'll have a look at it?
> >
> > By the way ... you could give the updated mavenizer a shot (sdk-utils in
> > the mavenizer-refactoring branch) and Flexmojos 7.1.0-SNAPSHOT as I have
> > put a lot of work in optimizing the Mavenization process.
> >
> > Chris
> >
> >
> > -----Urspr√ľngliche Nachricht-----
> > Von: Gary Yang [mailto:flashflexpro@gmail.com]
> > Gesendet: Montag, 28. Juli 2014 02:51
> > An: users@flex.apache.org
> > Betreff: Flexmojos 7.0.0 not working with 4.13.0.20140701
> >
> > Hi,
> >
> > this is the error:
> > [ERROR] Failed to execute goal
> > net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc
> > (default-compile-swc) on project module.flash.utils: Execution
> > default-compile-swc of goal
> > net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc failed: Flex
> > compiler and flex framework versions doesn't match. Compiler:
> > '4.12.0.20140303' - Framework: '4.13.0.20140701'.
> >
> >
> > if I change to flexmojos6.0.1, everything will be fine.
> >
> > thanks.
> >
> > -Gary
> >
>

Mime
View raw message