flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: AW: AW: AW: flex compilation diferent from maven compilation
Date Sat, 17 May 2014 11:33:17 GMT
Well you are specifying a non-default version of flex, but are using the default compiler.
You need to specify the compiler as dependency of the plugin.

I use this plugin configuration:

                <plugin>
                    <groupId>net.flexmojos.oss</groupId>
                    <artifactId>flexmojos-maven-plugin</artifactId>
                    <version>${flexmojos.version}</version>
                    <configuration>
                        <debug>true</debug>
                        <advancedTelemetry>true</advancedTelemetry>
                        <swfVersion>11</swfVersion>
                        <rslUrls>
                            <url>rsl/{artifactId}-{version}.{extension}</url>
                        </rslUrls>
                        <keepGeneratedActionscript>true</keepGeneratedActionscript>
                    </configuration>
                    <dependencies>
                        <!-- This handles a bug in maven which causes problems with flex
resources -->
                        <dependency>
                            <groupId>net.flexmojos.oss</groupId>
                            <artifactId>flexmojos-threadlocaltoolkit-wrapper</artifactId>
                            <version>${flexmojos.version}</version>
                        </dependency>
                        <!-- Without this FM will use the compiler configured in its
                        master pom, which will result in version conflicts -->
                        <dependency>
                            <groupId>org.apache.flex</groupId>
                            <artifactId>compiler</artifactId>
                            <version>${flex.version}</version>
                            <type>pom</type>
                        </dependency>
                    </dependencies>
                </plugin>

Hope it helps.

Chris

-----Urspr√ľngliche Nachricht-----
Von: Miguel Ferreira [mailto:miguel.cd.ferreira@hotmail.com] 
Gesendet: Freitag, 16. Mai 2014 10:33
An: users@flex.apache.org
Betreff: RE: AW: AW: AW: flex compilation diferent from maven compilation

Hi Chris,
I went forward.
I am using flexmojos 7.0.0
I mavenize the project with true in the end of the command i add that to my repository.
but when i run in my first sub project i get this error [ERROR] Failed to execute goal net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc
(default-compile-swc) on project bs2020FoundationFlex: Execution default-compile-swc of goal
net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc failed: Flex compiler and flex
framework versions doesn't match. Compiler: '4.12.0.20140303' - Framework: '3.5.0.12683'.[ERROR]
You can use 'iKnowWhatImDoingPleaseBreakMyBuildIwontBlameFlexmojosForStopWorking' to disable
this check.  Please refer to Flexmojos maven doc.[ERROR] If you prefer fixing it instead of
ignoring, take a look at: https://docs.sonatype.org/display/FLEXMOJOS/How+to+set+Flex+SDK+version[ERROR]
-> [Help 1]org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal
net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc (default-compile-swc) on project
bs2020FoundationFlex: Execution default-compile-swc of goal net.flexmojos.oss:flexmojos-maven-plugin:7.0.0:compile-swc
failed: Flex compiler and flex framework versions doesn't match. Compiler: '4.12.0.20140303'
- Framework: '3.5.0.12683'. You can use 'iKnowWhatImDoingPleaseBreakMyBuildIwontBlameFlexmojosForStopWorking'
to disable this check.  Please refer to Flexmojos maven doc.


But i add the dependecy 
<plugin>					<groupId>net.flexmojos.oss</groupId>					<artifactId>flexmojos-maven-plugin</artifactId>
				<version>${flexmojos.version}</version>					<extensions>true</extensions>
					<dependencies>						<dependency>							<groupId>org.apache.flex</groupId>
						<artifactId>compiler</artifactId>							<version>${flex.version}</version>
						<type>pom</type>						</dependency>												<dependency>
						<groupId>org.apache.flex.framework</groupId>							<artifactId>flex-framework</artifactId>
						<version>${flex.version}</version>							<type>pom</type>		
			</dependency>
</plugin>.....
Even in the project

	<dependencies>		<dependency>			<groupId>org.apache.flex.framework</groupId>
		<artifactId>flex-framework</artifactId>			<version>${flex.version}</version>
		<type>pom</type>


So, maybe you can point why he is looking for version 3.5 the default version.



Thanks in advance for the help
Miguel

> From: miguel.cd.ferreira@hotmail.com
> To: users@flex.apache.org
> Subject: RE: AW: AW: AW: flex compilation diferent from maven 
> compilation
> Date: Wed, 14 May 2014 15:12:07 +0100
> 
> 6.0.1 and is points for the 4.6.0 that i can not find ? there is a away to get that artifact
that i can pass it to the Nexus team?
> I can also update to the version 7 but in the nexus i could not find 
> it
> 
> > From: christofer.dutz@c-ware.de
> > To: users@flex.apache.org
> > Subject: AW: AW: AW: flex compilation diferent from maven 
> > compilation
> > Date: Tue, 13 May 2014 13:08:53 +0000
> > 
> > Hi Miguel,
> > 
> > yes I have an Artifactory in which I have all the artifacts. But No, 
> > I can't give you access to that. Aotherwise Adobe would probably 
> > start writing mad letters to me ;-)
> > 
> > What version of Flexmojos are you using? 6.x or 7.x?
> > 
> > Chris
> > ________________________________________
> > Von: Miguel Ferreira <miguel.cd.ferreira@hotmail.com>
> > Gesendet: Dienstag, 13. Mai 2014 11:00
> > An: users@flex.apache.org
> > Betreff: RE: AW: AW: flex compilation diferent from maven 
> > compilation
> > 
> > Hi Chris,
> > Even related to the topic,
> > Do you have a Nexus Proxy were i can connect to have the correct dependencies and
the correct versions?
> > Because in the pom file i have the dependency of  the flex compiler version 4.6.0
but i only can find the dependency for the version 4.6.b.And is a headache because i don't
"control" the Nexus environment, but, a can tell the Nexus team to open a Nexus proxy for
this dependency and that will solve my issue and also future dependencies problems where i
can update always the flexmojos without looking if the dependencies are correct or not.
> > 
> > Thank you,
> > Miguel
> > 
> > > From: christofer.dutz@c-ware.de
> > > To: users@flex.apache.org
> > > Subject: AW: AW: flex compilation diferent from maven compilation
> > > Date: Mon, 5 May 2014 11:13:56 +0000
> > >
> > > Hi Miguel,
> > >
> > > You can have a look at my confluence ... here I documented a lot of stuff back
in the days where I didn't have write Access to the Flexmojos Wiki:
> > > https://dev.c-ware.de/confluence/display/PUBLIC/Flexmojos+Section
> > > Especially this article should be a good starting point:
> > > https://dev.c-ware.de/confluence/display/PUBLIC/Configuring+your+p
> > > oms But I currently do see that these pages could use an update to 
> > > the latest Flexmojos and Apache Flex versions.
> > >
> > > Just come back if you have any problems.
> > >
> > > Chris
> > >
> > > ________________________________________
> > > Von: Miguel Ferreira <miguel.cd.ferreira@hotmail.com>
> > > Gesendet: Montag, 5. Mai 2014 12:04
> > > An: users@flex.apache.org
> > > Betreff: RE: AW: flex compilation diferent from maven compilation
> > >
> > > Hi Chris,
> > > I was waiting for your response!
> > > I enter in this project and a lot of libraries and etc are 1000 
> > > years old because i did not know Maven i let it be quiet there but in this
moment i was already reading and trying to update this historical version to a update one
:) Thanks for the links i will give it a try.
> > > Miguel
> > >
> > > > From: christofer.dutz@c-ware.de
> > > > To: users@flex.apache.org
> > > > Subject: AW: flex compilation diferent from maven compilation
> > > > Date: Mon, 5 May 2014 09:35:15 +0000
> > > >
> > > > Hi Miguel,
> > > >
> > > > well Flexmojos 3.6.1 is about 1000 Years old :-) It's not at all capable
of compiling with Apache Flex versions. If you want to use Apache Flex releases you have to
upgrade to Flexmojos 7.0.0 and currently you have to create the Mavenized version of the Flex
SDK by using our cool Mavenizer tool:
> > > > https://cwiki.apache.org/confluence/display/FLEX/Apache+Flex+SDK
> > > > +Mavenizer
> > > >
> > > > Flexmojos also has a new GroupId strarting from verion 5.x: net.oss.flexmojos.
I think having a look at this document is a good starting point:
> > > > https://flexmojos.atlassian.net/wiki/display/FLEXMOJOS/Migrating
> > > > +to+6.x
> > > >
> > > > The only main difference between Flexmojos 6 and 7 is that the Flex SDK
now has the group Id org.apache.flex instead of com.adobe.flex.
> > > >
> > > > Chris
> > > >
> > > > ________________________________________
> > > > Von: Miguel Ferreira <miguel.cd.ferreira@hotmail.com>
> > > > Gesendet: Montag, 5. Mai 2014 11:20
> > > > An: users@flex.apache.org
> > > > Betreff: flex compilation diferent from maven compilation
> > > >
> > > > Hi all,
> > > >
> > > > Last week i developed some menu items for the context menu in a flex application.
> > > > When i compile it with FB 4.7 every option is show without any problem
but when i compile with maven the context menu is always the default one?
> > > >
> > > > I am using SDK 4.10.flash version 10.0.45
> > > >
> > > > <properties>            <flex.version>4.10.0.20130801</flex.version>
           <flexmojos.version>3.6.1</flexmojos.version>            <flash.version>10.0.45</flash.version>
         <playerglobal.version>11.8</playerglobal.version>               <flexlib.classifier>flex3</flexlib.classifier>
         <target.dir>target</target.dir> </properties>
> > > > I am quite new with maven.
> > > > I can see that is a old version of flex mojos. Is that the solution? to
update to the most recent.
> > > > Or the compiler have to have some extra argument?
> > > > Thank you in advance for some feedback.
> > > > Miguel.
>  		 	   		  
 		 	   		  

Mime
View raw message