flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Franck Wolff <frawo...@gmail.com>
Subject Re: Any objections against dropping GraniteDS 1.x Generator in Flexmojos?
Date Fri, 04 Apr 2014 09:25:31 GMT
Gas3 (since version 2.3.2.GA) has LCDS templates and a LCDSAs3TypeFactory
which is generating AS3 Object fields for Java Maps (see this discussion in
the LCDS forum: http://forums.adobe.com/thread/1005496).

Basically, the configuration (Ant task, I don't know much about FlexMojos
configuration options) is:

<gas3
  as3typefactory="org.granite.generator.as3.LCDSAs3TypeFactory"
  entitytemplate="class:org/granite/generator/template/bean.gsp"

entitybasetemplate="class:org/granite/generator/template/lcdsBeanBase.gsp"
    interfacetemplate="class:org/granite/generator/template/interface.gsp"
    beantemplate="class:org/granite/generator/template/bean.gsp"
    beanbasetemplate="class:org/granite/generator/template/lcdsBeanBase.gsp"
    ...>

However, it generates [Managed] beans, which can be unsuitable with
BlazeDS... If somebody can contribute BlazeDS templates / type factory, I
would be happy to add them in the next GraniteDS release (you can post them
on our JIRA here: https://jira.granitedataservices.com/browse/GDS).

Franck
--
@graniteds



2014-04-04 0:20 GMT+02:00 Gary Yang <flashflexpro@gmail.com>:

> I think GAS will convert Java Map to Granite DS's IMap object, I have to
> change it back to object manually all the time.
>
>
> On Thu, Apr 3, 2014 at 6:16 PM, OmPrakash Muppirala <bigosmallm@gmail.com
> >wrote:
>
> > I dont specify a "generatorToUse" property.  What would it default to?
> >
> > Thanks,
> > Om
> >
> > On Thu, Apr 3, 2014 at 3:14 PM, OmPrakash Muppirala <
> bigosmallm@gmail.com>
> > wrote:
> > >
> > > Chris,
> > >
> > > I do use the Gas3 generator in my projects, but I am not sure which
> > version I am using.  How can I find out?
> > >
> > > Thanks,
> > > Om
> > >
> > >
> > > On Thu, Apr 3, 2014 at 3:09 PM, Christofer Dutz <
> > christofer.dutz@c-ware.de>
> > wrote:
> > >>
> > >> Hi,
> > >>
> > >> I'm currently finishing the task of supporting Jdk 1.7 and Maven 3.1
> and
> > 3.2 in Flexmojos.
> > >> A lot of trouble seem to be related to dependencies of the GraniteDS
> > Generator 1.x ... dropping this reduced the amount of trouble quite a
> lot.
> > >> I would therefore like to simply drop that generator. Unfortunately I
> > don't quite know if this would break anything with you guys.
> > >>
> > >> What do you think?
> > >>
> > >> Chris
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message