flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Saul Diaz" <cripito...@gmail.com>
Subject RE: IDE upgrade options
Date Tue, 29 Apr 2014 01:32:07 GMT
I Really wanna know why adobe don’t  upgrade 4.7 anymore

-----Original Message-----
From: Jeffry Houser [mailto:jeffry@dot-com-it.com] 
Sent: Monday, April 28, 2014 7:22 PM
To: users@flex.apache.org
Subject: Re: IDE upgrade options


On 4/28/2014 8:52 PM, Adam Malejko wrote:
> Long time Flex developer and lurker; never posted - never needed to.
>
> I finally got the go-ahead to upgrade to Flash Builder 4.7 premium a 
> little while ago, along with upgrading to the latest Apache Flex SDK. 
> Little did I know that the Flash Builder upgrade was not technically 
> possible. I have v3 and v4.5 premium keys (yet use v4.6), but no v4 
> premium or v4.5 standard key which would technically work to upgrade from.
>
> So after chatting and talking to Adobe representatives, I believe it's 
> time to look at my options.
>
> 1) Does anyone know how I can possibly upgrade to v4.7 without having 
> to buy the full $699 v4.7 license? $49 to upgrade from v4 sounds 
> great! Even
> $499 isn't terrible, but after sticking with them for this long I am 
> being forced to buy the full version for $699? Really? In the buying 
> guide [1], you see that "n/a" in there? That's me. SOL.


  Flash Builder 4.7 used to be a complimentary upgrade from 4.5/4.6 ( http://www.adobe.com/store/en_us/popup/offer/flashbuilder47_upgade.html
) but it looks like they discontinued that.  How odd.

  I bet that is the reason you can't upgrade from 4.5 premium to 4.7 premium on their web
site.  They discontinued one thing w/o adding an option.


> 2) I've used Flash Builder for many years now and haven't really 
> looked at the other options until recently. How do IntelliJ IDEA, FDT 
> and Flashdevelop compare from a developers perspective? I'm only 
> starting to write mobile apps which triggered the update from the Adobe SDK.

I love IntelliJ.  Although, I have never used it for Flex/Flash. But, it is great for HTML
stuff and for other stuff.



> 3) Should I just install the Apache Flex SDK in Flash Builder 4.6? Will
> that work for mobile apps?
  I have used Apache Flex w/ Flash Builder w/o issues.  It hink there 
was a minor issue fixed in 4.7 that had to do with files moving from 
html-template to bin-debug.


-- 
Jeffry Houser
Technical Entrepreneur
http://www.jeffryhouser.com
203-379-0773



Mime
View raw message