flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Poonam Anand <Poonam.An...@guavus.com>
Subject Re: AW: Apache Flex SDK Mavenizer SDK Deployer giving errors
Date Thu, 13 Mar 2014 09:29:52 GMT
Ok using mvn instead of mvm.bat worked as below on Mac:

java -cp target/flex-sdk-converter-1.0.jar SDKDeployer "/Users/poonam.anand/kiwik_workspace/apache/fdktarget/"
flex-releases http://station117.in.guavus.com:8081/artifactory/libs-release-local/ "/usr/local/apache-maven-3.0.4/bin/mvn"

Another issue I saw is it deployed only com.adobe.flex.framework artefacts. I had to run separate
as below for air and flash and com.adobe.flex.compiler. I had  earlier version of com.adobe.flex.compiler
under plugins-release-local instead of libs-release-local, so had put this one also to plugins-release-local.
Is this approach fine or I need to correct anything else.

java -cp target/flex-sdk-converter-1.0.jar SDKDeployer "/Users/poonam.anand/kiwik_workspace/apache/fdktarget/com/adobe/flex/compiler/"
flex-releases http://station117.in.guavus.com:8081/artifactory/plugins-release-local/ "/usr/local/apache-maven-3.0.4/bin/mvn"

java -cp target/flex-sdk-converter-1.0.jar SDKDeployer "/Users/poonam.anand/kiwik_workspace/apache/fdktarget/com/adobe/flash/"
flex-releases http://station117.in.guavus.com:8081/artifactory/libs-release-local/ "/usr/local/apache-maven-3.0.4/bin/mvn"

java -cp target/flex-sdk-converter-1.0.jar SDKDeployer "/Users/poonam.anand/kiwik_workspace/apache/fdktarget/com/adobe/air/"
flex-releases http://station117.in.guavus.com:8081/artifactory/libs-release-local/ "/usr/local/apache-maven-3.0.4/bin/mvn"

From: "Christofer Dutz [via Apache Flex Users]" <ml-node+s2333346n5447h24@n4.nabble.com<mailto:ml-node+s2333346n5447h24@n4.nabble.com>>
Date: Thursday, 13 March 2014 2:53 PM
To: Poonam Anand <poonam.anand@guavus.com<mailto:poonam.anand@guavus.com>>
Subject: AW: Apache Flex SDK Mavenizer SDK Deployer giving errors

Ok ... silly me :-)

Just had a look because I couldn't imagine that noone had tried on a non Windows machine.
The Problem is  you actually provide the path to the mvn start script as last Parameter ...
you provided the path to the Windows mvn runner and not the mac/unix/Linux one (.sh)
so instead of using mvn.bat, simply use mvn.sh and it should work on Linux.

Chris
________________________________________
Von: Poonam Anand <[hidden email]</user/SendEmail.jtp?type=node&node=5447&i=0>>
Gesendet: Donnerstag, 13. März 2014 08:25
An: [hidden email]</user/SendEmail.jtp?type=node&node=5447&i=1>
Betreff: Apache Flex SDK Mavenizer SDK Deployer giving errors

Hi,

I am using Apache Flex SDK Mavenizer SDK Deployer task to deploy mavenized
4.10 SDK artifacts to corporate artifcatory. Below given is command and
multiple same error blocks I am getting (listing 1 here).
It says Done also in the end. What does this mean, has it deployed or not? I
don't yet see artifacts on artifactory also.

java -cp target/flex-sdk-converter-1.0.jar SDKDeployer
"/Users/poonam.anand/kiwik_workspace/apache/fdktarget/" flex-releases
http://station117.in.guavus.com:8081/artifactory/libs-release-local/
"/usr/local/apache-maven-3.0.4/bin/mvn.bat"

/usr/local/apache-maven-3.0.4/bin/mvn.bat: line 1: @REM: command not found
/usr/local/apache-maven-3.0.4/bin/mvn.bat: line 2: syntax error near
unexpected token `('
/usr/local/apache-maven-3.0.4/bin/mvn.bat: line 2: `@REM Licensed to the
Apache Software Foundation (ASF) under one
'
Done.

Poonam




--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Apache-Flex-SDK-Mavenizer-SDK-Deployer-giving-errors-tp5440.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.


________________________________
If you reply to this email, your message will be added to the discussion below:
http://apache-flex-users.2333346.n4.nabble.com/Apache-Flex-SDK-Mavenizer-SDK-Deployer-giving-errors-tp5440p5447.html
To unsubscribe from Apache Flex SDK Mavenizer SDK Deployer giving errors, click here<http://apache-flex-users.2333346.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=5440&code=UG9vbmFtLkFuYW5kQGd1YXZ1cy5jb218NTQ0MHwtMTgzOTMwNjQxOA==>.
NAML<http://apache-flex-users.2333346.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>




--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Apache-Flex-SDK-Mavenizer-SDK-Deployer-giving-errors-tp5440p5448.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message