flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Poonam Anand <Poonam.An...@guavus.com>
Subject Flex mojos 6.0.1 and Flex SDK 4.10 - html wrapper goal giving error for swf type pom
Date Wed, 12 Mar 2014 14:40:32 GMT
I am using Flex mojos 6.0.1 and Flex SDK 4.10. Getting error as 'Failed to
execute goal net.flexmojos.oss:flexmojos-maven-plugin:6.0.1:wrapper
(default) on project sampleapplication: Execution default of goal
net.flexmojos.oss:flexmojos-maven-plugin:6.0.1:wrapper failed: 2 '

Not sure if I am missing something. Pom as below:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
		 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
		 xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/maven-v4_0_0.xsd">
	<modelVersion>4.0.0</modelVersion>
	<groupId>sampleapplication</groupId>
	<artifactId>sampleapplication</artifactId>
	<version>1.0-SNAPSHOT</version>
	<packaging>swf</packaging>
	<name>Sample Application</name>

	<properties>
		<flex.version>4.10.0.20130801</flex.version>
		<flexmojos.version>6.0.1</flexmojos.version>
	</properties>

	<build>
		<sourceDirectory>src/main/flex</sourceDirectory>

		<resources>
			<resource>
				<directory>src/main/resources</directory>
			</resource>
		</resources>

		<plugins>
			<plugin>
				<groupId>net.flexmojos.oss</groupId>
				<artifactId>flexmojos-maven-plugin</artifactId>
				<version>${flexmojos.version}</version>
				<extensions>true</extensions>

				<executions>
					<execution>
						<goals>
							<goal>wrapper</goal>
						</goals>
						<configuration>
							<parameters>
								<title>SampleApplication</title>
								<version_major>10</version_major>
								<application>SampleApplicationSWF</application>
								<width>100%</width>
								<height>100%</height>
							</parameters>
						</configuration>
					</execution>
				</executions>

				<dependencies>
					<dependency>
						<groupId>net.flexmojos.oss</groupId>
						<artifactId>flexmojos-threadlocaltoolkit-wrapper</artifactId>
						<version>${flexmojos.version}</version>
					</dependency>

					<dependency>
						<groupId>com.adobe.flex</groupId>
						<artifactId>compiler</artifactId>
						<version>${flex.version}</version>
						<type>pom</type>
					</dependency>
				</dependencies>

				<configuration>
					<templateURI>folder:html-wrapper-template/</templateURI>

					<sourceFile>SampleApplication.mxml</sourceFile>

					<finalName>SampleApplicationSWF</finalName>
					<htmlName>SampleApplicationSWF</htmlName>


					<source-path>
						<path-element>${project.build.sourceDirectory}</path-element>
						<path-element>src/main/resources</path-element>
					</source-path>

					<fonts>
						<managers>
							<manager>flash.fonts.CFFFontManager</manager>
						</managers>
					</fonts>

					<locales>
						<locale>en_US</locale>
					</locales>
					<targetPlayer>11.8</targetPlayer>
				</configuration>

			</plugin>
		</plugins>
	</build>
	<dependencies>
		<dependency>
			<groupId>kiwikapp</groupId>
			<artifactId>kiwikapp</artifactId>
			<version>1.0-SNAPSHOT</version>
			<type>swc</type>
		</dependency>
	</dependencies>
</project>




--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flex-mojos-6-0-1-and-Flex-SDK-4-10-html-wrapper-goal-giving-error-for-swf-type-pom-tp5409.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message