flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Chiappara <gchi...@gmail.com>
Subject Re: Error importing flexmojos 6 project into IntelliJ 13
Date Tue, 04 Feb 2014 00:50:02 GMT
I tried with that archetype but still no working. The strange thing is that
I can compile it using terminal. I think is shouldn't be a problem in the
pom. I'm using flex 4.11 and flexmojos 6.0.1 from command line without
problems...

I spent hours installing a virtual machine with ubuntu, maven, flex,
IntelliJ, etc. I cannot import a flexmojos in IntelliJ.


On Mon, Feb 3, 2014 at 8:14 PM, Christofer Dutz
<christofer.dutz@c-ware.de>wrote:

> I think you simply got the groupId of the archetype wrong.
> If I have a look at maven central the 6.0.1 is actually there:
>
> http://search.maven.org/#artifactdetails%7Cnet.flexmojos.oss%7Cflexmojos-archetypes-application%7C6.0.1%7Cmaven-archetype
>
> Give that a try ... 4.2 will be a no-go with Apache Flex.
>
> Chris
>
> -----Urspr√ľngliche Nachricht-----
> Von: Gonzalo Chiappara [mailto:gchiapp@gmail.com]
> Gesendet: Montag, 3. Februar 2014 21:56
> An: users@flex.apache.org
> Betreff: Re: Error importing flexmojos 6 project into IntelliJ 13
>
> I'm using flexmojos 6.0.1. I created my project using archetype version
> 4.2-beta because it's the last version in central repo (
> http://mvnrepository.com/artifact/org.sonatype.flexmojos/flexmojos-archetypes-application
> ).
>
> I think there's should be something wrong in my pom.xml or I'm not using
> the right version of maven or something.
>
> Can anyone post an example of pom.xml that works with IntelliJ 13?
>
>
> On Mon, Feb 3, 2014 at 5:55 PM, Christofer Dutz
> <christofer.dutz@c-ware.de>wrote:
>
> > Hi Gonzalo,
> >
> > First of all I think you should move to Flexmojos 6.0.1 or even
> > 7.0.0-SNAPSHOT.
> > The main problem is 4.x and 5.x were versions that only woked with the
> > Flex SDKs that Velo published to maven central.
> > No Apache Flex has ever been deployed there and the Apache way is to
> > manually provide a Mavenized version of Flex using the Mavenizer:
> > https://cwiki.apache.org/confluence/display/FLEX/Apache+Flex+SDK+Maven
> > izer
> >
> > I would strongly recommend to use the Archetype of version 6.0.1 or
> > 7.0.0-SNAPSHOT to generate your project stub as the 4.2 would need a
> > lot of tweaking to get it up and running.
> >
> > Chris
> >
> > -----Urspr√ľngliche Nachricht-----
> > Von: Gonzalo Chiappara [mailto:gchiapp@gmail.com]
> > Gesendet: Montag, 3. Februar 2014 19:24
> > An: users@flex.apache.org
> > Betreff: Error importing flexmojos 6 project into IntelliJ 13
> >
> > Hi. I need help with IntelliJ and flexmojos.
> >
> > I'm trying to import a flexmojos project into IntelliJ 13, but I'm
> > getting this message:
> >
> > "
> > These modules have been removed from maven structure:
> > 'testflex'
> > Do you want them to be removed from the project too?
> > "
> >
> > However I can build it successfully from the terminal (mvn package).
> >
> > There's no error or exception in IntelliJ log file.
> >
> > I created the project from a maven archetype using the following command:
> >
> >  mvn archetype:generate \
> > -DarchetypeGroupId=org.sonatype.flexmojos \
> > -DarchetypeArtifactId=flexmojos-archetypes-application \
> > -DarchetypeVersion=4.2-beta
> >
> >
> > Then I modified the pom.xml in order to use flexmojos 6 and flex 4.11.
> > This is the file:
> >
> > <?xml version="1.0" encoding="UTF-8"?> <project
> > xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
> > http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
> > http://maven.apache.org/POM/4.0.0
> > http://maven.apache.org/maven-v4_0_0.xsd
> > ">
> >   <modelVersion>4.0.0</modelVersion>
> >
> >   <groupId>test</groupId>
> >   <artifactId>testflex</artifactId>
> >   <version>1.0-SNAPSHOT</version>
> >   <packaging>swf</packaging>
> >
> >   <name>testflex Flex</name>
> >
> >   <properties>
> >     <flexmojos.version>6.0.1</flexmojos.version>
> >         <flex.version>4.11.0.20131017</flex.version>
> >         <flex.debug>true</flex.debug>
> >
> > <flex.flashPlayer.command>flashplayerdebugger</flex.flashPlayer.command>
> >   </properties>
> >
> >   <build>
> >     <sourceDirectory>src/main/flex</sourceDirectory>
> >     <testSourceDirectory>src/test/flex</testSourceDirectory>
> >     <plugins>
> >       <plugin>
> >         <groupId>net.flexmojos.oss</groupId>
> >         <artifactId>flexmojos-maven-plugin</artifactId>
> >         <version>${flexmojos.version}</version>
> >         <extensions>true</extensions>
> >         <configuration>
> >           <debug>true</debug>
> >         </configuration>
> >         <dependencies>
> >           <dependency>
> >             <groupId>com.adobe.flex</groupId>
> >             <artifactId>compiler</artifactId>
> >             <version>${flex.version}</version>
> >             <type>pom</type>
> >           </dependency>
> >         </dependencies>
> >       </plugin>
> >     </plugins>
> >   </build>
> >
> >   <dependencies>
> >     <dependency>
> >       <groupId>com.adobe.flex.framework</groupId>
> >       <artifactId>flex-framework</artifactId>
> >       <version>${flex.version}</version>
> >       <type>pom</type>
> >     </dependency>
> >
> >     <dependency>
> >       <groupId>com.adobe.flexunit</groupId>
> >       <artifactId>flexunit</artifactId>
> >       <version>0.85</version>
> >       <type>swc</type>
> >       <scope>test</scope>
> >     </dependency>
> >   </dependencies>
> >
> > </project>
> >
> > I'm using Ubuntu 13.10, IntelliJ 13.0.2 and maven 3.1.1.
> >
> > I don't know what's wrong.
> >
> > Thanks for you help
> >
> > Gonzalo.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message