flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Fritze <marcus.fri...@googlemail.com>
Subject Re: Problems openning PDF file using navigateToURL
Date Thu, 06 Feb 2014 12:30:17 GMT
This may help you: http://stackoverflow.com/questions/3487479/url-encode-variable-in-as3

Am 06.02.2014 um 13:24 schrieb Pedro Serralha <pedro.serralha@elegedata.com>:

> Greetings my friends
> 
> 
> 
> In our Webapplication we have some buttons that open an PDF file.
> 
> We are using the navigateToURL method.
> 
> 
> 
> The problem is that we are using bookmarks within the pdf and to open an
> link and point to an bookmark the URL used is something like
> 
> 
> 
> http://portal.beelogicsoftware.com/BeelogicIMS/manuals/pt_PT/BeelogicIMSChan
> geLog.pdf#pagemode=bookmarks&nameddest=Alterações no Portal
> 
> 
> 
> As you see, it accepts non standard characters on the URL as spaces and ç
> and õ. 
> 
> The link works with this characters if you put it directly on the browser,
> but when I open it using the method above mentioned it corrects the invalid
> characters.... and the bookmark pointer stops working.
> 
> 
> 
> http://portal.beelogicsoftware.com/BeelogicIMS/manuals/pt_PT/BeelogicIMSChan
> geLog.pdf#pagemode=bookmarks&nameddest=Altera%E7%F5es no Portal
> 
> 
> 
> 
> 
> So what I ask is, is there a way to open a link without these correction?
> 
> 
> 
> Thanks
> 
> 
> 
> Cumprimentos / Best Regards
> 
> Pedro Serralha
> 
> 
> 


Mime
View raw message