flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject AW: Problem migrating to Flexmojos 6: Failure to find com.adobe.flex.framework:halo:swc
Date Mon, 23 Dec 2013 11:35:12 GMT
Hi,

well actually this is an issue, but it should only have an effect on you if you are using
AIR. The problem is that you probably downloaded the FlexSDK without the AIR stuff. Then the
Mavenizer can't find the airglobal and the matching AIR sdk so it doesn't quite know which
AIR version to link to when generating the AIR artifacts. But as I said ... as long as you
don't use AIR there shouldn't be any problems.

When creating the mavenizer I cleaned up a lot of stuff that wasn't handled nicely in Flexmojos
till then. Depending on the version of the SDK some themes were provided as a simple css file,
some as a swc some as a bundle of resources. So what I did was to automatically compile any
theme that is not available in a compiled form to a compiled form. This way all themes are
available as SWC and SWFs. The Group ID has also changed slightly as I renamed the groupIds
of themes from com.adobe.flex.framework to com.adobe.flex.framework.themes. So you should
also change this (Think I'll add that to the migration docs on the Flexmojos Confluence).

Chris



-----Urspr√ľngliche Nachricht-----
Von: wim.deblauwe [mailto:wim.deblauwe@gmail.com] 
Gesendet: Montag, 23. Dezember 2013 10:43
An: users@flex.apache.org
Betreff: Re: Problem migrating to Flexmojos 6: Failure to find com.adobe.flex.framework:halo:swc

This the output of the Mavenizer:

wdb-laptop:mavenizer wdb$ java -cp target/flex-sdk-converter-1.0.jar SDKGenerator "/Applications/Libraries/sdk-4.10-home"
"/Applications/Libraries/sdk-4.10-target" false
---------------------------------------------
-- Generating Air SDK version: 3.9
---------------------------------------------
---------------------------------------------
---------------------------------------------
-- Generating Air SDK version: 3.8
---------------------------------------------
---------------------------------------------
---------------------------------------------
-- Generating Flex SDK version: 4.10.0.20130801
---------------------------------------------
Geneating theme 'AeonGraphical'
Loading configuration file
/Applications/Libraries/sdk-4.10-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.10-target/com/adobe/flex/framework/themes/aeongraphical/4.10.0.20130801/aeongraphical-4.10.0.20130801.swc
(41740 bytes)
Done.
Geneating theme 'Spark'
Loading configuration file
/Applications/Libraries/sdk-4.10-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.10-target/com/adobe/flex/framework/themes/spark/4.10.0.20130801/spark-4.10.0.20130801.swc
(2466 bytes)
Done.
Geneating theme 'MXFTEText.css'
Loading configuration file
/Applications/Libraries/sdk-4.10-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.10-target/com/adobe/flex/framework/themes/mxfte/4.10.0.20130801/mxfte-4.10.0.20130801.swc
(3461 bytes)
Done.
---------------------------------------------

I also ran it with Apache Flex 4.11 SDK:

wdb-laptop:mavenizer wdb$ java -cp target/flex-sdk-converter-1.0.jar SDKGenerator "/Applications/Libraries/sdk-4.11-home"
"/Applications/Libraries/sdk-4.11-target" false
---------------------------------------------
-- Generating Air SDK version: 3.9
---------------------------------------------
---------------------------------------------
---------------------------------------------
---------------------------------------------
-- Generating Flex SDK version: 4.11.0.20131017
---------------------------------------------
Couldn't find matching airglobal for FDK 4.11.0.20131017 Geneating theme 'AeonGraphical'
Loading configuration file
/Applications/Libraries/sdk-4.11-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.11-target/com/adobe/flex/framework/themes/aeongraphical/4.11.0.20131017/aeongraphical-4.11.0.20131017.swc
(41748 bytes)
Done.
Geneating theme 'Spark'
Loading configuration file
/Applications/Libraries/sdk-4.11-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.11-target/com/adobe/flex/framework/themes/spark/4.11.0.20131017/spark-4.11.0.20131017.swc
(2466 bytes)
Done.
Geneating theme 'MXFTEText.css'
Loading configuration file
/Applications/Libraries/sdk-4.11-home/flex/flex_sdk_4.11/frameworks/flex-config.xml
/Applications/Libraries/sdk-4.11-target/com/adobe/flex/framework/themes/mxfte/4.11.0.20131017/mxfte-4.11.0.20131017.swc
(3461 bytes)
Done.
---------------------------------------------


Is it an issue that it states: "Couldn't find matching airglobal for FDK 4.11.0.20131017"
 for the 4.11 SDK ?

Is it supposed to say "Generating theme 'Halo' " ?




--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Problem-migrating-to-Flexmojos-6-Failure-to-find-com-adobe-flex-framework-halo-swc-tp4254p4255.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message