flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OmPrakash Muppirala <bigosma...@gmail.com>
Subject Re: Safari browser never caches my Flex application, other browsers do
Date Thu, 31 Oct 2013 18:42:23 GMT
Can you try any other website (ex. flex.apache.org/installer.html) to see
if you can reproduce this issue?  If you can, then something is wrong with
the browser settings.  If not, you will have to further tweak your
.htaccess files.

Thanks,
Om


On Thu, Oct 31, 2013 at 11:36 AM, <modjklist@comcast.net> wrote:

> Unfortunately I can't post URL because the site is password protected per
> client's instructions until it's ready to go public.
>
> ----- Original Message -----
>
> From: "Thiago Maia" <a00s@a00s.com>
> To: users@flex.apache.org
> Sent: Thursday, October 31, 2013 11:30:16 AM
> Subject: Re: Safari browser never caches my Flex application, other
> browsers do
>
> Can you post the URL?
>
> thanks
> > Interesting, I'm observing that serving webpages over HTTPS:// causes
> Safari to never cache, whereas over HTTP:// Safari does cache.
> Unfortunately, I need to redirect all HTTP to HTTPS on my website.
> >
> > ----- Original Message -----
> >
> > From: modjklist@comcast.net
> > To: users@flex.apache.org
> > Sent: Thursday, October 31, 2013 10:43:04 AM
> > Subject: Re: Safari browser never caches my Flex application, other
> browsers do
> >
> > I should have mentioned the expire header for swf files is set in
> .htaccess to 1 month, so this shouldn't be the cause.
> >
> > ----- Original Message -----
> >
> > From: modjklist@comcast.net
> > To: "apache flex users" <users@flex.apache.org>
> > Sent: Thursday, October 31, 2013 10:37:23 AM
> > Subject: Safari browser never caches my Flex application, other browsers
> do
> >
> > Just went live with my first app, and I noticed whenever I click on the
> web link to open my app, Safari always downloads the swf file. Safari never
> pulls the swf file from cache after the first click.
> >
> > I went to other sites on the web, and their flex apps do get cached
> correctly in Safari.
> >
> > However, my app DOES cache correctly for all the other browsers
> (Firefox, Chrome, IE).
> >
> > Anyone see this before or know how to correct it?
> >
> > Note that (1) I don't have Private browsing enabled, (2) I verified in
> Safari's dev tools that cache is enabled, (3) my .htaccess file uses
> expires headers that request html files to always download (e.g.
> ExpiresByType text/html "access plus 0 seconds"), although changing this
> from 0 seconds to 1 month had no effect.
> >
> >
> >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message