flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurice Amsellem <maurice.amsel...@systar.com>
Subject RE: osmf.swc does not load with latest 4.11 version
Date Tue, 29 Oct 2013 08:58:49 GMT
Om, 

I was thinking we could change the Installer so that it will attempt to download OSMF several
times instead of one, and if eventually fails, prompt a message that says
"Could not download OSMF.swc,  you can download it manually at the following url:
....
And move it to <SDK>/Frameworks/Lib/

Maybe we could also change the downloading order so that it starts by downloading OSMF.
That way, user will see immediately any prompted message, instead of having it in the middle
of the 10min+ installation process.

What do you think?

Maurice 


-----Message d'origine-----
De : Hans J Nuecke [mailto:hnuecke@vservu.de] 
Envoyé : mardi 29 octobre 2013 00:24
À : users@flex.apache.org
Objet : Re: osmf.swc does not load with latest 4.11 version

Hi Om,
thanks for the clarification!
That's what I considered as the other option: copying osmf.swc over

But based on yours and Elena's input I did the installation again (I am using the latest installer,
btw) and it worked perfectly fine!
Now I got osmf.swc 2,0 with a size of 261k.
And it works perfectly fine (so far ;-)

Thanks and regards
Hans


Am 28.10.2013 18:28, schrieb OmPrakash Muppirala:
> Hans,
>
> It looks like the OSMF.swc download from Sourceforge runs into 
> problems from time to time.  We are not (yet) sure how to solve this permanently.
> Also, as Maurice hinted, make sure you get the latest Installer from here:
> flex.apache.org/installer.html.  There was a bug in an earlier version 
> that got fixed in the final release.
>
> In the meantime, the better option for you would be to copy the 
> osmf.swc from your RC2 installation into the 4.11 release installation directory.
>
> Hope this help.
>
> Regards,
> Om
>
>
> On Mon, Oct 28, 2013 at 5:48 AM, Hans Nuecke (bcc) <sfdc@vservu.de> wrote:
>
>> After installation of the latest 4.11 release my build with intelliJ 
>> failed with the error:
>> *unable to load  SWC osmf.swc
>>
>> *Somehow the osmf.swc in the new release is broken. It has a smaller 
>> file size (24k instead of 341k) and also cannot be opened with 7zip.
>>
>> Solution:
>> I reverted to the last 4.11 rc2, and everything works fine again.
>>
>> The latest installer reports an error, but it is said that that's a 
>> known bug and the installation worked fine nevertheless.
>> Just to let you know; I will continue to work with the release 
>> candidate as long as I do not hear this is solved.
>>
>>


Mime
View raw message