flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurice Amsellem <maurice.amsel...@systar.com>
Subject RE: compile error after installing SDK w/Flex Installer 2.7: unable to open /sdk/path/to/playerglobal.swc
Date Mon, 28 Oct 2013 18:22:02 GMT
I just checked the HTML wrapper options: there is a "check FP version" option.

Maurice 

-----Message d'origine-----
De : Maurice Amsellem [mailto:maurice.amsellem@systar.com] 
Envoyé : lundi 28 octobre 2013 19:17
À : users@flex.apache.org
Objet : RE: compile error after installing SDK w/Flex Installer 2.7: unable to open /sdk/path/to/playerglobal.swc

Good question.
I thought there was a test in the html wrapper javascript but can't be sure anymore.  
Can you do the test, please, maybe setting FP to 11.9, and checking with an older browser.

Maurice 

-----Message d'origine-----
De : modjklist@comcast.net [mailto:modjklist@comcast.net] Envoyé : lundi 28 octobre 2013
18:35 À : users@flex.apache.org Objet : Re: compile error after installing SDK w/Flex Installer
2.7: unable to open /sdk/path/to/playerglobal.swc

Problem resolved -- closing Flash Builder 4.7 then re-opening it and compiling eliminated
this error. 

One remaining question though... Is there any way to force users to use a minimum Flash Player
version? 

I *think* the purpose of using the compiler switch of -target-player=11.1 is to prevent compiling
in Flash Player features from newer versions of Flash Player. 

As the provider of a Flex app, is it my responsibility to inform users that they must use
version 11.1 or newer? Or, is there some way to auto-inform users when they try to run the
Flex app using versions older than 11.1 that the app won't run until they update Flash Player
to 11.1 or newer (and, hopefully, provide something to click on to launch an installer for
latest version)? 

----- Original Message -----

From: modjklist@comcast.net
To: users@flex.apache.org
Sent: Monday, October 28, 2013 10:20:11 AM
Subject: Re: compile error after installing SDK w/Flex Installer 2.7: unable to open /sdk/path/to/playerglobal.swc


I think it must be my error (not an Apache bug). I see the error references the path: 

/Applications/Adobe Flash Builder 4.7/sdks/Nightly/20131028/frameworks/libs/player/11.1/playerglobal.swc


But the only path in my directory is for 11.9, that is: 

/Applications/Adobe Flash Builder 4.7/sdks/Nightly/20131028/frameworks/libs/player/11.9/playerglobal.swc


When I installed the nightly build, the 11.9 Flash Player was selected. 

I checked my Project Properties > Flex Compiler settings, which shows: 

Adobe Flash Player options: "Use minimum version required by the Flex SDK" 
Additional compiler arguments includes the switch: -target-player=11.1 

I tried changing the -target-player=11.9, but it didn't help. 

----- Original Message ----- 

From: modjklist@comcast.net
To: users@flex.apache.org
Sent: Monday, October 28, 2013 10:08:04 AM
Subject: Re: compile error after installing SDK w/Flex Installer 2.7: unable to open /sdk/path/to/playerglobal.swc


Oops, you're right Alex, I got confused. Is this a bug? 

----- Original Message ----- 

From: "Alex Harui" <aharui@adobe.com>
To: users@flex.apache.org
Sent: Monday, October 28, 2013 9:59:30 AM
Subject: Re: compile error after installing SDK w/Flex Installer 2.7: unable to open /sdk/path/to/playerglobal.swc




On 10/28/13 9:54 AM, "modjklist@comcast.net" <modjklist@comcast.net> wrote: 

>Hi, I just upgraded the Apache Flex installer (from 2.6 to 2.7) then 
>downloaded the Nightly build and tried to compile a project with it.
>I'm getting a compile error for:
> 
>unable to open '/Applications/Adobe Flash Builder 
>4.7/sdks/Nightly/20131028/frameworks/libs/player.11.1/playerglobal.swc'
Probably need to be a slash instead of a ".' in player/11.1/ Check the air-config or flex-config.xml.
Search for playerglobal.swc 
> 
> 
>I believe I saw somewhere that playerglobal.swc has been changed to 
>expressInstall.swf due to licensing reasons. Is there a fix for this?
>Thanks in advance for any comments. 
No, playerglobal.swc exists. It is playerproductinstall.swf that was replaced by expressInstall.swf






Mime
View raw message