flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From modjkl...@comcast.net
Subject resizing browser window with Flex app running causes browsers to display white-screen
Date Tue, 15 Oct 2013 18:32:09 GMT
Anyone have experience with a browser displaying a white screen when resizing the browser's
window while running a Flex app? 

I have a scroller in my app that appears whenever the user resizes the app smaller than some
minimum WxH that I've predefined. Lately, I've been working to optimize all the screens' layouts
to account for when this scroller is shown or not. In the process, I have to resize the browser
window to make this scroller appear or not appear. That's when I discovered that during this
process of resizing the browser window, the browser, at some point (if I wait long enough
while resizing), will always show a white screen. Closing the browser window and re-running
the app thereafter displays a white screen (again). The only solution is to kill the browser
application then re-run the app. 

Recently, I started my app and simply clicked the window-maximum button in the browser's title
bar and the white screen appeared. This got me thinking about it more seriously, since typical
users may see the same thing (e.g. if it can occur with simply one resize). 

So far, it occurs for any application I can create. I've attached a simple example application
below for anyone interested to try themselves. Just run the app, left-click the window-resize
icon, hold, then drag the resize icon in circles for a minute or two (stopping periodically
(e.g. unclicking the left-button) to see if the application is still responsive). At some
point, for me at least, while resizing the app, the screen blinks white, and from that moment
on, the problem reveals itself. Making the browser window larger shows a white screen. Closing
the window and re-running the app also shows a white screen. The app appears to be running
(making the window smaller sometimes shows the running application), it's just displaying
a white screen for certain window sizes. 

I'm using Shockwave Flash 11.9.900.117. 

It occurs for me in SDK 4.5.1, and 4.10.0 (the only two I tried). There are no Flex debug
errors or browser errors/warnings generated. 

It occurs for me in Firefox (v24.0), Chrome(v 30.0.1599.69), and Safari (5.1.10), which are
all the browsers I have access to. 

It occurs when running the app in debug or non-debug mode. 

Just wondering if anyone else in the community ran into this (is it a known issue)? If so,
how do people address this? 

Thanks in advance for any comments. 


------ example application: click+drag window-resize icon in circles until screen appears
white or unresponsive ----------- 



<?xml version="1.0" encoding="utf-8"?> 
<s:Application xmlns:fx="http://ns.adobe.com/mxml/2009" 
xmlns:s="library://ns.adobe.com/flex/spark" 
xmlns:mx="library://ns.adobe.com/flex/mx" minWidth="500" minHeight="300"> 

<s:VGroup paddingLeft="20" paddingTop="20"> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
<s:Label text="This is some label text."/> 
</s:VGroup> 

</s:Application> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message