flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric THOMAS <webdoubl...@hotmail.com>
Subject RE: AW: 4.10.0 Maven Artifacts
Date Mon, 09 Sep 2013 13:47:46 GMT
1- Ah ok, then look at
http://www.mnkartik.com/2013/01/could-not-transfer-artifact-error-400.html

What I usually do for artifacts not built and deployed from Maven project as
this one, is I create another repository, I use it for what I add manually
with "Allow Redeploy" snapshots and releases. 

2- You didn't answered my question from the previous email.

-Fred

-----Message d'origine-----
De : Davori [mailto:lyndon.fasanya@lgim.com] 
Envoyé : lundi 9 septembre 2013 15:29
À : users@flex.apache.org
Objet : RE: AW: 4.10.0 Maven Artifacts

Additinally when I inspect my repo i see this even though the output from
the deployer command instruction is as such for many of the artifacts:

Uploading:
http://10.204.30.56:8082/nexus/content/repositories/Maven3Repository/
com/adobe/flex/framework/advancedgrids/4.10.0.20130801/advancedgrids-4.10.0.
2013
0801.pom
326/326 B

[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 0.563s
[INFO] Finished at: Mon Sep 09 14:23:38 BST 2013 [INFO] Final Memory:
6M/495M [INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.7:
deploy-file (default-cli) on project flex-sdk-converter: Failed to deploy
artifa
cts: Could not transfer artifact
com.adobe.flex.framework:advancedgrids:rb.swc:e
l_GR:4.10.0.20130801 from/to snapshots
(http://10.204.30.56:8082/nexus/content/r
epositories/Maven3Repository): Failed to transfer file:
http://10.204.30.56:8082
/nexus/content/repositories/Maven3Repository/com/adobe/flex/framework/advanc
edgr
ids/4.10.0.20130801/advancedgrids-4.10.0.20130801-el_GR.rb.swc. Return code
is:
400, ReasonPhrase:Bad Request. -> [Help 1] [ERROR] [ERROR] To see the full
stack trace of the errors, re-run Maven with the -e swit ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please
rea d the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
Done.
[INFO] Scanning for projects...
[INFO]
[INFO]
------------------------------------------------------------------------
[INFO] Building flex-sdk-converter 1.0
[INFO]
------------------------------------------------------------------------
[INFO]
[INFO] --- maven-deploy-plugin:2.7:deploy-file (default-cli) @
flex-sdk-converte r ---
Uploading:
http://10.204.30.56:8082/nexus/content/repositories/Maven3Repository/
com/adobe/flex/framework/advancedgrids/4.10.0.20130801/advancedgrids-4.10.0.
2013
0801-en_AU.rb.swc
2/4 KB
4/4 KB

Uploading:
http://10.204.30.56:8082/nexus/content/repositories/Maven3Repository/
com/adobe/flex/framework/advancedgrids/4.10.0.20130801/advancedgrids-4.10.0.
2013
0801.pom
326/326 B

[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 0.578s
[INFO] Finished at: Mon Sep 09 14:23:39 BST 2013 [INFO] Final Memory:
6M/495M [INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.7:
deploy-file (default-cli) on project flex-sdk-converter: Failed to deploy
artifa
cts: Could not transfer artifact
com.adobe.flex.framework:advancedgrids:rb.swc:e
n_AU:4.10.0.20130801 from/to snapshots
(http://10.204.30.56:8082/nexus/content/r
epositories/Maven3Repository): Failed to transfer file:
http://10.204.30.56:8082
/nexus/content/repositories/Maven3Repository/com/adobe/flex/framework/advanc
edgr
ids/4.10.0.20130801/advancedgrids-4.10.0.20130801-en_AU.rb.swc. Return code
is:
400, ReasonPhrase:Bad Request. -> [Help 1] [ERROR]

I understand that process may say fail if the artifact is already in the
repo - is this correct?

Additionally does the process end or does it keep trying to upload artifacts
that failed previously?

Finally am I missing any dependencies outside 4.10.0.XXXX that I have to
upload manually.



--
View this message in context:
http://apache-flex-users.2333346.n4.nabble.com/4-10-0-Maven-Artifacts-tp2616
p2629.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message