flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Ent <p...@adobe.com>
Subject Re: FlexJS
Date Thu, 22 Aug 2013 17:40:23 GMT
Did you select the main app and then compile it with the external tools
(Run->External Tools->FlexJS) ? And even if you did, it is possible that
automatic compilation in Flash Builder could have decided to re-compile
the code on you. Best to turn that off if you can.

Peter Ent
Flex SDK Team
Adobe Systems

On 8/22/13 12:28 PM, "Alex Harui" <aharui@adobe.com> wrote:

>Instead of starting from scratch, try modifying an existing example.
>
>Go here: 
>http://people.apache.org/~aharui/FlexJS/DataBindingTest/bin-release/DataBi
>n
>dingTest.html
>
>Right-click and choose View Source.
>
>-Alex
>
>On 8/22/13 9:24 AM, "mark goldin" <markzolotoy@gmail.com> wrote:
>
>>Now when I am running this:
>><?xml version="1.0" encoding="utf-8"?>
>><basic:Application
>>xmlns:fx="http://ns.adobe.com/mxml/2009"<http://ns.adobe.com/mxml/2009>
>>                   xmlns:basic="library://ns.apache.org/flexjs/basic"
>>                   >
>></basic:Application>
>>I am getting the following error:
>>TypeError: Error #1009: Cannot access a property or method of a null
>>object
>>reference. at
>>org.apache.flex.core::Application/initHandler()[/Users/aharui/git/flex/ma
>>s
>>ter/flex-asjs/frameworks/as/src/org/apache/flex/core/Application.as:58]
>>Any idea?
>>On Wed, Aug 21, 2013 at 5:02 PM, mark goldin <markzolotoy@gmail.com>
>>wrote:
>>
>>> Yes, you are correct. After coping the whole FlexJSOverlay folder into
>>> c:\temp it worked fine. Thanks!!!!
>>>
>>>
>>> On Wed, Aug 21, 2013 at 4:56 PM, Alex Harui <aharui@adobe.com> wrote:
>>>
>>>> I would advise against having both a c:\Temp and c:\temp folders.  I
>>>> didn't even think it was possible on Windows.
>>>>
>>>> Are you sure that you copied all of FlexJSOverlay to c:\Temp?  It is
>>>> acting like just the .bat file is there.
>>>>
>>>> -Alex
>>>>
>>>> ----------
>>>>
>>>> From:  mark goldin <markzolotoy@gmail.com>
>>>> Reply-To:  "users@flex.apache.org" <users@flex.apache.org>
>>>> Date:  Wednesday, August 21, 2013 2:43 PM
>>>> To:  "users@flex.apache.org" <users@flex.apache.org>
>>>> Subject:  Re: FlexJS
>>>>
>>>>
>>>> Nope, still the same.
>>>> Console:
>>>> C:\Temp>deploy.bat C:\temp\4.10.0 C:\temp\FlexJS > c:\log1.txt
>>>> '.*' is not recognized as an internal or external command,
>>>> operable program or batch file.
>>>> '.*' is not recognized as an internal or external command,
>>>> operable program or batch file.
>>>> File not found - *.*
>>>> File not found - *.*
>>>> File not found - *.*
>>>> File not found - *.*
>>>> File not found - *.*
>>>> File not found - *.*
>>>> File not found - *.*
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>> 'setuplaunches.bat' is not recognized as an internal or external
>>>>command,
>>>> operable program or batch file.
>>>>
>>>>
>>>> File: Attached
>>>>
>>>>
>>>>
>>>> On Wed, Aug 21, 2013 at 4:28 PM, Alex Harui
>>>> <aharui@adobe.com> wrote:
>>>>
>>>> OK, I think I know what is going on.  I got fooled by thinking you'd
>>>> copied the entire console output into the email.  The log file implies
>>>> that deploy.bat is having problems because ther eis a space in the
>>>>path to
>>>> FlexJSOverlay.  Try moving it out of "Program Files" to some path
>>>>without
>>>> spaces.
>>>>
>>>> -Alex
>>>>
>>>>
>>>> From:  mark goldin <markzolotoy@gmail.com>
>>>> Reply-To:  "users@flex.apache.org" <users@flex.apache.org>
>>>> Date:  Wednesday, August 21, 2013 2:14 PM
>>>> To:  "users@flex.apache.org" <users@flex.apache.org>
>>>> Subject:  Re: FlexJS
>>>>
>>>>
>>>> It worked fine with xcopy.
>>>> But not with deploy.bat. I redirected output into a file. Here is what
>>>>the
>>>> console shows:
>>>> C:\Program Files\Adobe\FlexJSOverlay>deploy.bat C:\temp\4.10.0
>>>> C:\temp\FlexJS >
>>>> c:\log1.txt
>>>> '.*' is not recognized as an internal or external command,
>>>> operable program or batch file.
>>>> '.*' is not recognized as an internal or external command,
>>>> operable program or batch file.
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> Invalid number of parameters
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>> The system cannot find the file specified.
>>>>
>>>>
>>>> and attached is the output file.
>>>>
>>>>
>>>>
>>>> On Wed, Aug 21, 2013 at 3:39 PM, Alex Harui
>>>> <aharui@adobe.com> wrote:
>>>>
>>>> If you haven't, try it from the command line, see if it works, and
>>>>report
>>>> the output if it doesn't.  It won't create a FlexJS SDK, but at least
>>>> we'll know if that step can work at all.
>>>>
>>>> Then try it again from deploy.bat and see if it works and report the
>>>> output if it doesn't work.  It may have failed for different reasons
>>>>than
>>>> your earlier attempts.
>>>>
>>>> -Alex
>>>>
>>>> On 8/21/13 1:36 PM, "mark goldin" <markzolotoy@gmail.com> wrote:
>>>>
>>>> >I probably misunderstood. I did not run it manually. I used
>>>>deploy.bat.
>>>> >Are
>>>> >you saying you I need to run xcopy (the same that is in the deploy
>>>>file)
>>>> >manually from command line?
>>>> >
>>>> >
>>>> >On Wed, Aug 21, 2013 at 3:33 PM, Alex Harui <aharui@adobe.com>
wrote:
>>>> >
>>>> >> Your replies indicate that you tried to run xcopy from the commmand
>>>> >>prompt
>>>> >> and it did not copy flex-sdk-description.xml and other files.  If
>>>> that's
>>>> >> true, what was the console output?
>>>> >>
>>>> >> -Alex
>>>> >>
>>>> >> On 8/21/13 1:31 PM, "mark goldin" <markzolotoy@gmail.com>
wrote:
>>>> >>
>>>> >> >Alex,
>>>> >> >What do you mean by "manual xcopy"?
>>>> >> >
>>>> >> >
>>>> >> >On Wed, Aug 21, 2013 at 3:26 PM, Alex Harui <aharui@adobe.com>
>>>>wrote:
>>>> >> >
>>>> >> >> Mark,
>>>> >> >>
>>>> >> >> There's a good chance we'll solve this problem faster if
you
>>>>take
>>>> the
>>>> >> >>time
>>>> >> >> to answer all of the questions we ask of you.
>>>> >> >>
>>>> >> >> What was the output from the manual xcopy?  If a manual
xcopy
>>>>won't
>>>> >>work
>>>> >> >> there may be some permissions issue with the destination
folder
>>>>or
>>>> >>maybe
>>>> >> >> xcopy usage is restricted somehow.
>>>> >> >>
>>>> >> >> -Alex
>>>> >> >>
>>>> >> >> On 8/21/13 1:12 PM, "mark goldin" <markzolotoy@gmail.com>
wrote:
>>>> >> >>
>>>> >> >> >No, I checked,  source SDK has these files.
>>>> >> >> >
>>>> >> >> >
>>>> >> >> >On Wed, Aug 21, 2013 at 2:59 PM, Alex Harui <aharui@adobe.com>
>>>> >>wrote:
>>>> >> >> >
>>>> >> >> >> Well, that implies that the manual copy you made
of
>>>> >> >> >>
>>>> >> >> >> "C:\Program Files\Adobe\Adobe Flash Builder 4.7
(64
>>>> >>Bit)\sdks\4.10.0"
>>>> >> >> >>
>>>> >> >> >>
>>>> >> >> >> was not correct, or the folder you copied is also
not a valid
>>>> Flex
>>>> >> >>SDK.
>>>> >> >> >> Please make sure that C:\temp\4.10.0 contains
a valid copy of
>>>>a
>>>> >>Flex
>>>> >> >>SDK
>>>> >> >> >> before attempting to run deploy.bat.
>>>> >> >> >>
>>>> >> >> >> -Alex
>>>> >> >> >>
>>>> >> >> >> On 8/21/13 12:54 PM, "mark goldin" <markzolotoy@gmail.com>
>>>> wrote:
>>>> >> >> >>
>>>> >> >> >> >Yes, no, no.
>>>> >> >> >> >C:\Program Files\Adobe\FlexJSOverlay>xcopy
/s
>>>>C:\temp\4.10.0\*.*
>>>> >> >> >> >C:\temp\FlexJS
>>>> >> >> >> >
>>>> >> >> >> >
>>>> >> >> >> >On Wed, Aug 21, 2013 at 2:43 PM, Alex Harui
>>>><aharui@adobe.com>
>>>> >> >>wrote:
>>>> >> >> >> >
>>>> >> >> >> >> Did you verify that your copy in C:\temp\4.10.0
has
>>>> >> >>frameworks/libs,
>>>> >> >> >> >> flex-sdk-description.xml, and frameworks/flex-config.xml?
>>>> >> >> >> >>
>>>> >> >> >> >> What does the output to the console now
say at the point
>>>>of
>>>> the
>>>> >> >> >>xcopy?
>>>> >> >> >> >>
>>>> >> >> >> >> -Alex
>>>> >> >> >> >>
>>>> >> >> >> >> On 8/21/13 11:46 AM, "mark goldin" <markzolotoy@gmail.com>
>>>> >>wrote:
>>>> >> >> >> >>
>>>> >> >> >> >> >C:\Program Files\Adobe\FlexJSOverlay>deploy.bat
>>>> C:\temp\4.10.0
>>>> >> >> >> >> >C:\temp\FlexJS
>>>> >> >> >> >> >
>>>> >> >> >> >> >same problem - no Flex SDK
>>>> >> >> >> >> >
>>>> >> >> >> >> >
>>>> >> >> >> >> >On Wed, Aug 21, 2013 at 1:40 PM,
OmPrakash Muppirala
>>>> >> >> >> >> ><bigosmallm@gmail.com>wrote:
>>>> >> >> >> >> >
>>>> >> >> >> >> >> Instead of
>>>> >> >> >> >> >> C:\Users\*****>"C:\Program
>>>> >> >>Files\Adobe\FlexJSOverlay\deploy.bat"
>>>> >> >> >> >> >> "C:\Program
>>>> >> >> >> >> >> iles\Adobe\Adobe Flash Builder
4.7 (64
>>>>Bit)\sdks\4.10.0"
>>>> >> >> >> >> >>"C:\temp\FlexJS" >
>>>> >> >> >> >> >> c:\l
>>>> >> >> >> >> >> og.txt
>>>> >> >> >> >> >>
>>>> >> >> >> >> >> can you try:
>>>> >> >> >> >> >>
>>>> >> >> >> >> >> C:\Program Files\Adobe\FlexJSOverlay>deploy.bat
>>>>"C:\Program
>>>> >> >> >> >> >> iles\Adobe\Adobe Flash Builder
4.7 (64
>>>>Bit)\sdks\4.10.0"
>>>> >> >> >> >> >>"C:\temp\FlexJS" >
>>>> >> >> >> >> >> c:\l
>>>> >> >> >> >> >> og.txt
>>>> >> >> >> >> >>
>>>> >> >> >> >> >> That is, run deploy.bat from
its directory.  That seems
>>>>to
>>>> >>be
>>>> >> >>the
>>>> >> >> >> >>only
>>>> >> >> >> >> >> difference between my successful
attempt and yours.
>>>> >> >> >> >> >>
>>>> >> >> >> >> >>
>>>> >> >> >> >> >>
>>>> >> >> >> >> >> On Wed, Aug 21, 2013 at 11:35
AM, mark goldin
>>>> >> >> >><markzolotoy@gmail.com
>>>> >> >> >> >
>>>> >> >> >> >> >> wrote:
>>>> >> >> >> >> >>
>>>> >> >> >> >> >> > I ran it without quotes
- same.
>>>> >> >> >> >> >> >
>>>> >> >> >> >> >> >
>>>> >> >> >> >> >> > On Wed, Aug 21, 2013 at
1:21 PM, Alex Harui
>>>> >> >><aharui@adobe.com>
>>>> >> >> >> >>wrote:
>>>> >> >> >> >> >> >
>>>> >> >> >> >> >> > > I wonder if the bat
file is having problems with
>>>>spaces
>>>> >>in
>>>> >> >>the
>>>> >> >> >> >>path
>>>> >> >> >> >> >>and
>>>> >> >> >> >> >> > > the surrounding quotes.
 Can you try manually
>>>>copying
>>>> >>the
>>>> >> >> >>source
>>>> >> >> >> >> >> folders
>>>> >> >> >> >> >> > > to a place without
spaces and then run deploy
>>>>without
>>>> >> >>quotes?
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > > -Alex
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > > ---------
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> > >
>>>> >> >> >> >> >> >
>>>> >> >> >> >> >>
>>>> >> >> >> >>
>>>> >> >> >> >>
>>>> >> >> >>
>>>> >> >> >>
>>>> >> >>
>>>> >> >>
>>>> >>
>>>> >>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>


Mime
View raw message