flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Compatibility - Adobe Flash Builder
Date Wed, 14 Aug 2013 22:36:13 GMT


On 8/14/13 2:45 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>> I still think we have to be careful about this statement.  With FB 4.6
>> there is an HTML wrapper issue that can bite someone.
>
>But for day to day development work there no issue there.
Maybe not for you, but at least one person has already tripped over this.
And since another failure case can happen after deployment, I think folks
should be aware that FB 4.6 has more issues than FB 4.7.

>
>I  can't recall a single web project I've worked on that didn't use a
>custom HTML wrapper.
That's great, but folks still have to be careful in how they customize the
HTML wrapper.

FlashBuilder 4.6 is looking to copy playerProductInstall.swf from the
SDK's templates folder into your output folder.  Apache Flex switched to
SWFObject's expressInstall.swf for licensing reasons.  The default .html
file for Apache Flex will reference expressInstall.swf.  FlashBuilder 4.6
will not copy that file.  IIRC, as long as you have the right FP
installed, the wrapper will work fine, but if an upgrade is needed, I
think it won't work.

And if you use old HTML wrappers that reference playerProductInstall.swf
to wrap Apache Flex SWFs you will also find that swf missing if an upgrade
is needed.

-Alex


Mime
View raw message