flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Compatibility - Adobe Flash Builder
Date Wed, 14 Aug 2013 20:37:26 GMT
The answer is actually quite complex.

FB 4.6 was tested with Flex SDK 4.6 which was tested with FP 11.1 and AIR
3.1 (see release notes [1].  You can swap in other versions of SDKs and
FPs and AIR, and it should work mostly, but I'm not sure what would happen
if you called Adobe support for help if you didn't have the tested
configuration.

For sure, FB 4.6 will not properly generate the HTML wrapper for any
Apache Flex-based SWF.  That's why FB 4.7 was released.  It is the only
version of FB that can correctly generate the HTML template for an Apache
Flex SDK.

IIRC, if you use FB 4.6 to generate the wrapper for an Apache Flex-based
app, the only thing that is broken with the wrapper is the player
detection, so if you leverage some fancy feature of a later FP and a
customer doesn't have that version, the code that should warn the user and
offer an upgrade won't run and your SWF may not run either.

Most folks simply aren't going to run into this, but now you have been
warned...

[1] 
http://helpx.adobe.com/flash-builder/release-note/flex-4-6-sdk-release.html

-Alex

On 8/14/13 1:14 PM, "Stephen C" <stephen@stephenjc.com> wrote:

>just to clarify, you can update the AIR sdk separately from the flex sdk.
>So i am using flex sdk 4.6 in fb 4.6 with air 3.8 sdk.
>
>Thank You,
>Stephen C
>-All of my email addresses go to the same place
>-Save Paper, think before you print
>-PGP Public 
>Key<https://docs.google.com/file/d/0B0JeFeQj5XjkZC0talFuRExyc0E/edit?usp=s
>haring>
>
>
>On Wed, Aug 14, 2013 at 4:09 PM, Julio Carneiro <julio@4ctv.com> wrote:
>
>> afaik, FB 4.6 is compatible with all versions of the SDK, from Adobe's
>>4.6
>> to Apache Flex 4.10.
>> the only thing is that you loose Design mode for any SDK higher than
>> Adobe's 4.6. All else works the same.
>>
>> On Aug 14, 2013, at 3:53 PM, Lucas Lacerda <lucasjohn@gmail.com> wrote:
>>
>> > Hey guys...
>> > Does anyone know what version of Adobe Air and Flex SDK is compatible
>> with
>> > each Flash Builder version? For example FB 4.6
>> > Is there any where I can find this content?
>> >
>> > Thanks.
>>
>> --
>> Julio Carneiro
>>
>>
>>


Mime
View raw message