flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From manitas manitas <manitas0...@gmail.com>
Subject Re: Pb with special characters and accents
Date Wed, 28 Aug 2013 22:04:41 GMT
Thanks for your answer.

I have just test to put an accent directly in the trace function like this
 : trace("é");
And there is the same encoding issue so it should not be a problem from the
TextInput.

You said I can't rely on the trace function but this encoding problem also
appears when I directly the "é" to a remote server using the POST method of
an URLRequest.

I'm completely stucked, do you have any idea how to investigate further ?


2013/8/28 Alex Harui <aharui@adobe.com>

> trace() is a low-level Flash debugger feature.  I'm not sure you can rely
> on it regarding character sets.
>
> On 8/28/13 1:56 PM, "manitas manitas" <manitas0302@gmail.com> wrote:
>
> >Hi,
> >
> >I'm using the apache flex 4.10 sdk to develop an Adobe Air desktop app for
> >Windows.
> >
> >I have a problem with special characters and accents.
> >
> >In fact all my mxml file starts with the following line :
> ><?xml version="1.0" encoding="UTF-8"?>
> >
> >but when I try to get the text of a spark TextInput and trace it in the
> >output console or send it to a remote server there is a problem of charset
> >encoding.
> >
> >For example if I type "é" in the TextInput the display is ok in the app
> >but
> >if I get and trace the text of this TextInput I have this : é
> >
> >I don't know what I'm missing and where to find the encoding configuration
> >for my app.
> >
> >Thanks in advance for your help.
> >
> >Best regards
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message