flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Dahmen" <fr...@dahmenia.de>
Subject Re: -services services-config.xml
Date Mon, 01 Jul 2013 06:27:17 GMT
hi,thanks for answer
i didn't need a remoting-config.xml when using the adobe sdk
this is my services-config.xml:

<?xml version="1.0" encoding="UTF-8"?>
<services-config>
    <services>
        <service id="amfphp-flashremoting-service" 
class="flex.messaging.services.RemotingService" 
messageTypes="flex.messaging.messages.RemotingMessage">
            <destination id="zend">
                <channels>
                    <channel ref="my-zend"/>
                </channels>
                <properties>
                    <source>*</source>
                </properties>
            </destination>
        </service>
    </services>
    <channels>
        <channel-definition id="my-zend" 
class="mx.messaging.channels.AMFChannel">
            <endpoint uri="###the-uri###" 
class="flex.messaging.endpoints.AMFEndpoint"/>
        </channel-definition>
    </channels>
</services-config>

as i said i just put -services services-config.xml in the compiler options
and it worked, the file is in the project root in flashdevelop

I didn't change anything but switchingthe sdk from adobe's 4.6 to the apache 
4.9.1

Thanks



----- Original Message ----- 
From: "Thiago Maia" <a00s@a00s.com>
To: <users@flex.apache.org>
Sent: Monday, July 01, 2013 8:13 AM
Subject: Re: -services services-config.xml


> Hello
>
>      Dont forget the remoting-config.xml -)
>
> Thiago Maia
>
>> Hi,
>>
>> i migrated from adobe's sdk to the new apache sdk, I'm using 
>> Flashdevelop.
>> In my project I'm using Amfphp, so i have a services-config.xml in the 
>> project root.
>> In the compiler options (flashdevelop) i put "-services 
>> services-config.xml"
>> this worked with the adobe sdk (same project), but with the apache sdk i 
>> get :
>>
>> faultCode:InvokeFailed faultString:'[MessagingError message='Destination 
>> 'zend' either does not exist or the destination has no channels defined 
>> (and the application does not define any default channels.)']' 
>> faultDetail:'Couldn't establish a connection to 'zend''
>>
>> I downloaded the sdk with the BlazeDS option selected .
>> What I'm doing wrong?
>>
>> Thanks 


Mime
View raw message