flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurice Amsellem <maurice.amsel...@systar.com>
Subject RE: Apache Flex 4.10 Release Candidate
Date Wed, 31 Jul 2013 19:04:11 GMT
Thanks, I will raise a JIRA for that.

FYI, the installation went well with the latest install. All files downloaded properly.
I will now compile with the new SDK. 

Regards,

Maurice 

-----Message d'origine-----
De : omuppi1@gmail.com [mailto:omuppi1@gmail.com] De la part de OmPrakash Muppirala
Envoyé : mercredi 31 juillet 2013 20:55
À : users@flex.apache.org
Objet : Re: Apache Flex 4.10 Release Candidate

On Wed, Jul 31, 2013 at 11:45 AM, Maurice Amsellem < maurice.amsellem@systar.com> wrote:

> Hi,
>
> " The key is that in your shared code, you need to make sure that you 
> use the runtime features from the lower swf-version.".
> Thanks for the advice. I guess that's what I am doing already,  the 
> features from AIR 3.X are in non-shared, mobile-only code.
>
> " Yes, it does.  Unfortunately, the AIR 3.8 requires a swf-version 
> that is different from FP 10.2.  We tied the AIR/FP versions with same 
> swf-versions together so that users don't get into trouble.".
>
> I understand, but this is not only for 3.8 and 10.2. All FP Versions 
> have a minimum AIR version, and you can't go beyond.  So what does "Yes it does"
> mean?
>

Sorry, the "yes it does" was for your question: "Does this make sense to you?" :-)


> The check is fine, but it should be possible to manually override.
> So maybe in a future release.
>

We debated this and thought it would be better for users if we kept swf-versions straightforward.
 Please log a bug about your request so that we dont forget it.


>
> Note: regarding the double installation, it's going to take too long, 
> so I will run the installer once to download FP 11.8 and AIR 3.8, and 
> then manually patch FP 10.2 on to it (flex-config.xml, and framework/lib/player).
>

The installer takes care of patching all the config files (air-config.xml, airmobile-config.xml
and flex-config.xml)  But it is up to you.  I am too lazy to do all this manually - which
is my primary motivation for building the Installer ;-)


>
> Thanks again for the help,
>

You are most welcome!


>
> Maurice
>
> -----Message d'origine-----
> De : omuppi1@gmail.com [mailto:omuppi1@gmail.com] De la part de 
> OmPrakash Muppirala Envoyé : mercredi 31 juillet 2013 20:27 À : 
> users@flex.apache.org Objet : Re: Apache Flex 4.10 Release Candidate 
> (ERROR)
>
> On Wed, Jul 31, 2013 at 11:17 AM, Maurice Amsellem < 
> maurice.amsellem@systar.com> wrote:
>
> > The installer does not allow me to select AIR 3.8 and FlashPlayer 
> > 10.2 at the same time  ( I guess because of dependencies).
> > However in my case, I am using AIR for mobile apps (and needs the 
> > latest
> > version) and FP for Flex browser app (and need 10.2), so there is no 
> > connection between the two.
> > Does this make sense to you?
> >
> > PS: I didn't even notice than the previous installation did it fact 
> > download AIR SDK 2.6 :-(
> >
> >
> Yes, it does.  Unfortunately, the AIR 3.8 requires a swf-version that 
> is different from FP 10.2.  We tied the AIR/FP versions with same 
> swf-versions together so that users dont get into trouble.
>
> In your case, you can:
>
> 1.  Run the installer twice (one for each combination) 2.  Copy over 
> the correct versions of air-config.xml, airmobile-config.xml and 
> flex-config.xml into one master sdk folder.
> 3.  Copy over the required flash player swc directory ex.
> frameworks/libs/player/10.2 into the master sdk folder
>
> The key is that in your shared code, you need to make sure that you 
> use the runtime features from the lower swf-version.
>
> Hope that helps.
>
> Om
>
>
>
>
>
> >  Maurice
> >
> > -----Message d'origine-----
> > De : omuppi1@gmail.com [mailto:omuppi1@gmail.com] De la part de 
> > OmPrakash Muppirala Envoyé : mercredi 31 juillet 2013 20:07 À :
> > users@flex.apache.org Objet : Re: Apache Flex 4.10 Release Candidate
> > (ERROR)
> >
> > On Wed, Jul 31, 2013 at 11:05 AM, Maurice Amsellem < 
> > maurice.amsellem@systar.com> wrote:
> >
> > > Thanks for fixing so quickly.
> > >
> > > Since the installer log says " Impossible de nettoyer les 
> > > répertoires d'installation temporaires", which means "could not 
> > > delete temp install directories", do I have to delete something 
> > > manually before
> > starting over ?
> > >
> >
> > Yes, you may want to delete the 'temp' directory that was created 
> > during the installation before continuing to install in the same place.
> >
> > Thanks,
> > Om
> >
> >
> > >
> > > Maurice
> > >
> > > -----Message d'origine-----
> > > De : omuppi1@gmail.com [mailto:omuppi1@gmail.com] De la part de 
> > > OmPrakash Muppirala Envoyé : mercredi 31 juillet 2013 20:01 À :
> > > users@flex.apache.org Objet : Re: Apache Flex 4.10 Release 
> > > Candidate
> > > (ERROR)
> > >
> > > On Wed, Jul 31, 2013 at 10:50 AM, Maurice Amsellem < 
> > > maurice.amsellem@systar.com> wrote:
> > >
> > > > I have tried installing latest Flex SDK 4.10 RC3 using SDK 
> > > > Installer
> > > > 2.6.0
> > > > (Windows) and the installation breaks in the middle.
> > > >
> > > > Installation options:
> > > > - SdK 4.10 RC3
> > > > - AIR 3.8
> > > > - FP 10.2
> > > > Language = French
> > > > OS = Windows 7
> > > >
> > > > Installation Error log below  (sorry, it's in French):
> > > >
> > > > I guess the error comes from the missing "/" in the player 
> > > > global
> URL.
> > > >
> > > > Version 2.6.0 (windows)
> > > > L'URL de téléchargement du SDK à été récupéré à partir du CGI.
> > > > AIR version 2.6
> > > > Flash Player version 10.2
> > > > Creation du dossier racine d'Apache Flex Création du répertoire 
> > > > temporaire Téléchargement d'Apache Flex SDK à partir de:
> > > > https://dist.apache.org/repos/dist/dev/flex/sdk/4.10.0/rc3/binar
> > > > ie s/ ap ache-flex-sdk-4.10.0-bin.zip Vérification de la 
> > > > Signature Apache Flex SDK MD5 La Signature MD5 des fichiers 
> > > > téléchargés pour le SDK Apache Flex correspond à la référence. 
> > > > Le fichier est valide.
> > > > Décompression: C:\Program Files (x86)\Apache 
> > > > Flex\Apache_Flex_SDK_410_RC3\temp\apache-flex-sdk-4.10.0-bin.zip
> > > > Décompression terminée:C:\Program Files (x86)\Apache 
> > > > Flex\Apache_Flex_SDK_410_RC3\temp\apache-flex-sdk-4.10.0-bin.zip
> > > > Téléchargement d'Adobe AIR Runtime Kit pour Windows à partir de:
> > > > http://airdownload.adobe.com/air/win/download/2.6/AdobeAIRSDK.zi
> > > > p
> > > > Décompression: C:\Program Files (x86)\Apache 
> > > > Flex\Apache_Flex_SDK_410_RC3\temp\AdobeAIRSDK.zip
> > > > Décompression terminée:C:\Program Files (x86)\Apache 
> > > > Flex\Apache_Flex_SDK_410_RC3\temp\AdobeAIRSDK.zip
> > > > Installation d'Adobe Flash Player playerglobal.swc à partir de:
> > > > http://download.macromedia.com/get/flashplayer/installers/archiv
> > > > e/ pl ay erglobalplayerglobal10_2.swc Impossible de télécharger 
> > > > Flash Player swc Impossible de nettoyer les répertoires 
> > > > d'installation temporaires Installation interrompue
> > > >
> > > > Maurice
> > > >
> > >
> > > Maurice,
> > >
> > > Thanks for catching that!  I have fixed the config file, it should 
> > > work fine now.  Please try again and verify.  You will need to 
> > > exit the installer and launch it again for the updated config file to load.
> > >
> > > Regards,
> > > Om
> > >
> > >
> > >
> > > >
> > > > -----Message d'origine-----
> > > > De : Krüger, Olaf [mailto:OKrueger@edscha.com] Envoyé : lundi 29 
> > > > juillet 2013 10:30 À : users@flex.apache.org Objet : AW: Apache 
> > > > Flex
> > > > 4.10 Release Candidate
> > > >
> > > >
> > > > >RC2 is out (it has a couple of minor issues but will give you a 
> > > > >working
> > > > SDK) , but you might want to wait for RC3.
> > > > >https://dist.apache.org/repos/dist/dev/flex/installer/2.6/rc2/
> > > >
> > > > Do you mean RC3 of the installer or RC3 of the SDK?
> > > > Cause I've just started the installer from the link above and it 
> > > > already provides the SDK 4.10.0 RC3 !?
> > > >
> > > > Many thanks!
> > > > Olaf
> > > >
> > > >
> > > > ________________________________
> > > >
> > > > Edscha Holding GmbH
> > > > Sitz der Gesellschaft: Remscheid
> > > > Registergericht: Wuppertal, HRB 22889
> > > > Geschäftsführung: Francisco J. Riberas Mera, Juan Maria Riberas 
> > > > Mera, Francisco López Peña, David Vázquez Pascual, Torsten 
> > > > Greiner, Mario Eikelmann, Hans-Peter Schulz und Volker Weiss
> > > >
> > > > Vertretungsberechtigt sind nur Geschäftsführer und schriftlich 
> > > > Bevollmächtigte.
> > > >
> > > > Solely Managing Directors or employees with a written proxy have 
> > > > got power of representation.
> > > >
> > > > Der Inhalt dieser E-Mail einschließlich etwaiger beigefügter 
> > > > Dateien ist vertraulich und nur für den Empfänger bestimmt.
> > > > Sollten Sie nicht der bestimmungsgemäße Empfänger sein, ist 
> > > > Ihnen jegliche Offenlegung, Vervielfältigung, Weitergabe oder 
> > > > Nutzung des Inhalts untersagt. Bitte informieren Sie in diesem 
> > > > Fall unverzüglich den Absender und löschen Sie die E-Mail 
> > > > einschließlich etwaiger beigefügter Dateien von Ihrem
> > > System.
> > > > Vielen Dank.
> > > >
> > > > The contents of this e-mail including any attachments are 
> > > > confidential and may be legally privileged. If you are not the 
> > > > intended recipient, any disclosure, copying, distribution or use 
> > > > of its contents is strictly prohibited, and you should please 
> > > > notify the sender immediately and then delete this e-mail 
> > > > including any attachments from
> > > your system. Thank you.
> > > >
> > >
> >
>

Mime
View raw message