flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "christofer.dutz@c-ware.de" <christofer.d...@c-ware.de>
Subject AW: AW: AW: how to setup and use maven-flex-plugin
Date Thu, 02 May 2013 22:31:52 GMT
Hi Dan,

I can reproduce this problem and I'll have a look into it as soon as I am able to spare some
time ... eventually this weekend.

Chris

-----Urspr√ľngliche Nachricht-----
Von: Dan Rollo [mailto:danrollo@gmail.com] 
Gesendet: Donnerstag, 2. Mai 2013 23:32
An: users@flex.apache.org
Betreff: AW: AW: AW: how to setup and use maven-flex-plugin

Hi Chris and Fred,

I've banked my simple test project in github here:
git@github.com:bhamail/flexmojos-test.git

I don't see anything in this project that could possibly include 4.6 artifacts (and the maven
error says the FM plugin is trying to resolve those old artifacts). But I'm a total flex noob.

Does anyone have a FDK 4.9.1 ONLY env to try building this in?

The output of dependency:tree in my "hacked environment" is below (but it is possibly different
in an env with real FDK 4.6 artifacts?). 
("hacked environment" has some 4.9.1 artifacts republished as 4.6 to workaround FM resolve
errors).

[INFO]
------------------------------------------------------------------------
[INFO] Building lib-model Flex 1.0.0-SNAPSHOT [INFO]
------------------------------------------------------------------------
[INFO]
[INFO] --- maven-dependency-plugin:2.1:tree (default-cli) @ lib-model --- [INFO] com.myco.model:lib-model:swc:1.0.0-SNAPSHOT
[INFO] +- com.adobe.flex.framework:flex-framework:pom:4.9.1.1447119:compile
[INFO] |  +-
com.adobe.flex.framework:common-framework:pom:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:sparkskins:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:spark_dmv:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:apache:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:mx:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:spark:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:rpc:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:textLayout:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:experimental:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:osmf:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:charts:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:flash-integration:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:authoringsupport:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:core:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:advancedgrids:swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:framework:swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:framework:zip:configs:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:apache:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:mx:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:spark:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:rpc:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:textLayout:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:experimental:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +- com.adobe.flex.framework:charts:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:flash-integration:rb.swc:4.9.1.1447119:compile
[INFO] |  |  +-
com.adobe.flex.framework:advancedgrids:rb.swc:4.9.1.1447119:compile
[INFO] |  |  \-
com.adobe.flex.framework:framework:rb.swc:4.9.1.1447119:compile
[INFO] |  \- com.adobe.flash.framework:playerglobal:swc:11.1:compile
[INFO] +- com.adobe.flash.framework:playerglobal:rb.swc:11.4:external
(scope not updated to compile)
[INFO] \- org.flexunit:flexunit:swc:flex4:4.1.0:test
[INFO]
------------------------------------------------------------------------

If you run dependency:tree in your env, do you get the same result?

Maybe I'm one of the first to run FM with FDK 4.9.1 without already having FDK 4.6 available?
- the joys of being a noob? :)

Thanks,
Dan



--------------------------------
I just had a look at the pom of flexmojos-maven-plugin and could not find a reference to the
framework:pom artifact except it being mentioned in the dependencyManagement section.

I did have a look at the dependencies of the mojo though and could see that the only thing
having a dependency on the framework:pom was the com.adobe.flex:compiler:pom ... I added this
dependency in there to allow checking the correct version of the flex core libs. But as you
are overriding this and in com.adobe.flex:compiler:pom: 4.9.1.1447119

But having a look at your pom I just saw the error. You are adding the dependencies to the
plugin classpath and not the artifact classpath. So just remove all of the "swc" and "swc.rb"
dependencies from the plugin that it just contains the compiler:pom dependency.

Chris

Mime
View raw message