flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Baird <mba...@kairyt.com>
Subject Application issues building through Ant
Date Tue, 09 Apr 2013 00:41:41 GMT
I have a large application with multiple shared libraries and sub-modules
that I'm trying to build through Ant and I'm running into issues... hoping
someone here can help.

I'm currently targeting the latest AF release - 4.9.1 - and running into an
issue where when I launch the Ant-built application, I receive one Flash
exception:
VerifyError: Error #1014: Class mx.controls::Button could not be found.
then another:
ReferenceError: Error #1065: Variable
_88d866d22da27af4b5978eeb7ebb39d5d661776417e03b75890d49335a9fed4d_flash_display_Sprite
is not defined.

This seems to indicate that the Flash player is not being included somehow
but I can't figure out why!

Here is an example of one of my module targets:
    <target name="dashboard"
            depends="client">
        <java jar="${mxmlc.jar.path}"
              failonerror="true"
              fork="true">
            <jvmarg value="-Xmx512m"/>
            <arg value='-debug=${debug}'/>
            <arg
value='-local-fonts-snapshot=${FLEX_HOME}/frameworks/localFonts.ser'/>
            <arg
value='-load-config=${FLEX_HOME}/frameworks/flex-config.xml'/>
            <arg
value='-theme=${FLEX_HOME}/frameworks/themes/Halo/halo.swc'/>
            <arg value='-source-path+=${lib.dashboard}'/>
            <arg value='-runtime-shared-libraries=${core.swf}'/>
            <arg value='-external-library-path=${build.dir}/core.swc'/>
            <arg value='-runtime-shared-libraries=${common.swf}'/>
            <arg value='-external-library-path=${build.dir}/common.swc'/>
            <arg value='-runtime-shared-libraries=${charting.swf}'/>
            <arg value='-external-library-path=${build.dir}/charting.swc'/>
            <arg
value='-file-specs=${lib.dashboard}/${view.dir}/DashboardView.mxml'/>
            <arg
value='-output=${build.dir}/${view.dir}/DashboardView.swf'/>
            <arg value='-load-externs=${build.dir}/report.xml'/>
        </java>
    </target>

FLEX_HOME is defined earlier in the build script as the path to the 4.9.1
base directory.

I have also tried using anttasks, and that is working a little better
except when I load a module with charts - then I get another missing class:
VerifyError: Error #1014: Class mx.charts::CategoryAxis could not be found.

So overall it seems like I'm having linking issues, but I'm using stock
flex-configs that look like they are including the right libraries in the
right places.

Any help is appreciate... thanks =)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message