flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric THOMAS <webdoubl...@hotmail.com>
Subject Re: Ant build error about java
Date Wed, 13 Mar 2013 11:40:33 GMT
I use Ant 1.8.4 without troubles, not completly sure but I guess your 
problem is you use the JRE instead of the JDK

-Fred

-----Message d'origine----- 
From: Cyrill Zadra
Sent: Wednesday, March 13, 2013 12:31 PM
To: users@flex.apache.org
Subject: Re: Ant build error about java

Is "C:\Program Files\Java\jre7" really a JDK? Not just the JRE?.

I'm not sure if anybody has ever built Apache Flex with ant 1.8. I
think 1.7.0 is the tested version.

Cyrill

On Wed, Mar 13, 2013 at 9:26 PM, Kessler CTR Mark J
<mark.kessler.ctr@usmc.mil> wrote:
>
>    Was setting up a new PC to be able to build the flex-sdk from the 
> development branch and ran into an error with ANT.  I ran a standard Ant 
> build from the Flex-SDK folder (root of flex folder).  It seems to be 
> having an issue with Java, but the paths are correct.  Are we still 
> supposed to be on jdk 1.6 instead of 1.7?
>
>
> Environment:
> Flex-sdk - lastest as of yesterday (cloned main repo and changed to 
> development branch).
> Ant - 1.8
> Java - 1.7
> Flashglobal - 11.1
>
> All the environmental variables are set and their bin folders included in 
> the path.
>
>
> BUILD FAILED
> D:\Development\Flex\Flex-SDK\build.xml:344: The following error occurred 
> while executing this line:
> D:\Development\Flex\Flex-SDK\modules\build.xml:158: The following error 
> occurred while executing this line:
> D:\Development\Flex\Flex-SDK\modules\thirdparty\xerces-patch\build.xml:52: 
> Unable to find a javac compiler;
> com.sun.tools.javac.Main is not on the classpath.
> Perhaps JAVA_HOME does not point to the JDK.
> It is currently set to "C:\Program Files\Java\jre7"
>
>
> -Mark
> 


Mime
View raw message