flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject Re: Flash Player version for Apache Flex 4.9
Date Fri, 22 Feb 2013 22:58:48 GMT
Hi,

> I don't recall off-hand what doesn't compile with 10.1, but it would not be
> my choice to lose parity with Adobe Flex 4.6.


This is the first issue - not sure of other issues after that.

compile:
     [echo] Compiling frameworks/libs/framework.swc
    [compc] Loading configuration file /Users/justinmclean/Documents/ApacheFlexDevelop/frameworks/flex-config.xml
    [compc] Loading configuration file /Users/justinmclean/Documents/ApacheFlexDevelop/frameworks/projects/framework/framework-config.xml
    [compc] Loading configuration file /Users/justinmclean/Documents/ApacheFlexDevelop/frameworks/projects/framework/compile-config.xml
    [compc] /Users/justinmclean/Documents/ApacheFlexDevelop/frameworks/projects/framework/src/mx/managers/SystemManager.as(3561):
col: 52 Error: Access of possibly undefined property softKeyboardRect through a reference
with static type flash.display:Stage.
    [compc] 
    [compc]             var softKeyboardRect:Rectangle = stage.softKeyboardRect;
    [compc]                                                    ^
    [compc] 

Justin
Mime
View raw message