flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mihai Ene <dkra...@yahoo.com>
Subject Targeting both older and newer versions of FP
Date Tue, 11 Sep 2012 10:14:37 GMT
Hey guys, hope I'm not bothering too much with these questions.

Can Apache Flex 4.8.0 be used to target both Flash Player 10.1 and Flash Player 11.4?

Project details:

I have a project with 2 video streams, input and output. It is currently built with Adobe
Flex 4.5.1A for 10.1 support but I would like to have newer features for newer players (such
as echo cancellation - 10.3, and GPU video rendering - 11.4). Older flash player versions
can play newer -swf-version, but the compiler will not compile for minimum version 10.1 if
functions available in 11.4 are used in the project.

Detailed question:

Can Apache Flex 4.8.0 target older FP versions (modifying .xml file for minimum version) and
build code only available in playerglobal-v11.4.swc? If i copy the 11.4 playerglobal.swc in
the 10.1 folder, will it compile? I can handle different FP versions in my project (simple
if-else), but the problem is with the compiler, since it throws errors if I include 11.4 functionality
and target FP10.1...

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message