flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Patrick (Jira)" <j...@apache.org>
Subject [jira] [Created] (FLEX-35407) bundle v4.2.1 reporting warnings with multi release version jar
Date Wed, 09 Oct 2019 15:41:00 GMT
John Patrick created FLEX-35407:
-----------------------------------

             Summary: bundle v4.2.1 reporting warnings with multi release version jar
                 Key: FLEX-35407
                 URL: https://issues.apache.org/jira/browse/FLEX-35407
             Project: Apache Flex
          Issue Type: Bug
            Reporter: John Patrick


When using maven-bundle-plugin with multi release I get the following;
{code:java}
[WARNING] Bundle io.cucumber:gherkin:bundle:5.1.1-SNAPSHOT : Split package, multiple jars
provide the same package:META-INF/versions/11
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:., Jar:gherkin-jvm-deps]
Class path         [Jar:., Jar:gherkin-jvm-deps]
[WARNING] Bundle io.cucumber:gherkin:bundle:5.1.1-SNAPSHOT : Classes found in the wrong directory:
{META-INF/versions/11/module-info.class=module-info}
{code}
 

With Java 9 and and Multi Release Jars, I might have any of the following in multiple jar
files;
{code:java}
module-info.class
META-INF/versions/9/module-info.class
META-INF/versions/10/module-info.class
META-INF/versions/11/module-info.class
META-INF/versions/12/module-info.class
META-INF/versions/13/module-info.class
{code}
 

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message