flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sami Al-beik (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLEX-35403) FOR 5 YEARS THE INSTALLER HASN*T WORKED FLAWLESSLY
Date Sat, 20 Jul 2019 19:55:00 GMT
Sami Al-beik created FLEX-35403:
-----------------------------------

             Summary: FOR 5 YEARS THE INSTALLER HASN*T WORKED FLAWLESSLY
                 Key: FLEX-35403
                 URL: https://issues.apache.org/jira/browse/FLEX-35403
             Project: Apache Flex
          Issue Type: Bug
          Components: Installer
    Affects Versions: Apache Flex 4.16.1
            Reporter: Sami Al-beik


My good, never ever has the installer ever worked flawlessly. There's ALWAYS something that
isn't working, there's always some time where it fails. CAN SOMEBODY PLEASE FIX THE INSTALLER
-> IT NEVER WORKED. I have had multiple fresh installs of the entire computer, on windows
and on max, I have tried to install it on virtual machines and none-virtual. Sometimes it
works and sometimes (most times) it doesn't. It's always the same it fucking fails during
the process - mostly when when installering the Air sdk .... 8/10 times that's the reason.
I have to go get the sdk mylself and install it manuelly ... can't continue the process ...
have to copy the flex sdk from others and put it all together manuelly and make it work. 

 

ALSO WHO THE F# MADE THE 32bit-> 64 bit part? Sometimes this retard implementation is failing.
It discovers that the system is 64bit -> it closes ... yeah and then its crashing and can't
start the 64bit version. Now how can I install the SDK if the installer is crashing on startup.
MAKE A 64BIT BINARY AND MAKE A 32 BIT BINARY -> give the user to start the version they
need. 

 

Now it might all just be some really poor error messages - IT ALLWAYS JUST TELLS US THAT IT
FAILED - Now what should I use this for ? WTF is wrong? give us some useful info, THE INFO
MUST BE SO THAT WE KNOW WHAT TO DO TO FIX IT. The guy who is handling the error messages ->
FIRE HIM, for 5 years he has been giving us USELESS error messages.

 

+++++++++++++++++++++++++++


Here's my latest (1 out of 50 bad experiences):

Installer path: /private/var/folders/nx/7mp7dkms6x35g5mf93c5mddc0000gn/T/AppTranslocation/E96A3CF1-6456-4458-80AC-870C27CE8A6B/d/Apache
Flex SDK Installer.app/Contents/Resources
Installer version 3.3.2 (mac)
Using Locale: da_DK
Fetched the SDK download mirror URL from the CGI.
SDK version Apache Flex SDK 4.16.1
AIR version 32.0
Flash Player version 32.0
Creating Apache Flex home
Creating temporary directory
Downloading Apache Flex SDK from: http://mirrors.rackhosting.com/apache/flex/4.16.1/binaries/apache-flex-sdk-4.16.1-bin.tar.gz
Verifying Apache Flex SDK MD5 Signature
The Apache Flex SDK MD5 Signature of the downloaded files matches the reference. The file
is valid.
Uncompressing: /Users/sami/Documents/Air SDK 4.16 - air 32/temp/apache-flex-sdk-4.16.1-bin.tar.gz
Finished uncompressing: /Users/sami/Documents/Air SDK 4.16 - air 32/temp/apache-flex-sdk-4.16.1-bin.tar.gz
Downloading Adobe AIR Runtime Kit for Mac from: https://airdownload.adobe.com/air/mac/download/32.0//AdobeAIRSDK.dmg
Validating download: /Users/sami/Documents/Air SDK 4.16 - air 32/in/AdobeAIRSDK.dmg
Should unzip: ${shouldUnzip}
Mounting dmg
IS WINDOWS: ${isWindows}, IS MAC: mac
Copying AIR SDK from mounted volume
Unmounting AIR SDK
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/frameworks/libs/air
to /Users/sami/Documents/Air SDK 4.16 - air 32/frameworks/libs
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/frameworks/projects/air
to /Users/sami/Documents/Air SDK 4.16 - air 32/frameworks/projects
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/include to /Users/sami/Documents/Air
SDK 4.16 - air 32
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/lib/android to /Users/sami/Documents/Air
SDK 4.16 - air 32/lib
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/lib/aot to /Users/sami/Documents/Air
SDK 4.16 - air 32/lib
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/lib/nai to /Users/sami/Documents/Air
SDK 4.16 - air 32/lib
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/runtimes to /Users/sami/Documents/Air
SDK 4.16 - air 32
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/samples/badge to
/Users/sami/Documents/Air SDK 4.16 - air 32/samples
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/samples/icons to
/Users/sami/Documents/Air SDK 4.16 - air 32/samples
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/templates/air to
/Users/sami/Documents/Air SDK 4.16 - air 32/templates
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/templates/extensions
to /Users/sami/Documents/Air SDK 4.16 - air 32/templates
Copying files from /Users/sami/Documents/Air SDK 4.16 - air 32/in/airsdk/templates/sdk to
/Users/sami/Documents/Air SDK 4.16 - air 32/templates
Installing Adobe Flash Player playerglobal.swc from: https://fpdownload.macromedia.com/get/flashplayer/updaters/32//playerglobal32_0.swc
Validating download: /Users/sami/Documents/Air SDK 4.16 - air 32/frameworks/libs/player/32.0/playerglobal.swc
Flash SDK download failed
Installation aborted: http://flex.apache.org/track-installer.html?failure=true&label=Apache
Flex SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.2&info=&info=Flash%20SDK%20download%20failed

 

 

 



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message