flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pan Li (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLEX-35206) Javascript isn't produced correctly when beads are not the first element of View
Date Wed, 07 Dec 2016 09:09:59 GMT

     [ https://issues.apache.org/jira/browse/FLEX-35206?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pan Li updated FLEX-35206:
--------------------------
    Description: 
{code}
    <js:View >
	<js:Container height="320" width="721" style="border:1px solid">
	</js:Container>
	<js:beads>
		<js:ViewDataBinding/>
	</js:beads>
         <js:Label text="something"/>

</js:View>
{code}

Above code doesn't report error when building to html/javascript, but when running it doesn't
show the label control.
In awf mode it runs without problem.

There could be other unexpected behavior when bead is not the top element and the UI has more
elements or files:
Sometimes it build but when running it stop in javascript error. Sometimes it builds but after
the normal building process the SDK reports "javascript" building error. I could not reproduce
them with simple sample for now

  was:
{code}
    <js:View >
	<js:Container height="320" width="721" style="border:1px solid">
	</js:Container>
	<js:beads>
		<js:ViewDataBinding/>
	</js:beads>
         <js:Label text="something"/>

</js:View>
{code}

Above code doesn't report error when building to html/javascript, but when running it doesn't
show the label control.
In awf mode it runs without problem.

There could be other behavior when bead is not the top element and the UI has more elements
or files.
Sometimes it build but when running it stop in javascript error. Sometimes it builds but after
the normal building process the SDK reports "javascript" building error. I could not reproduce
them with simple sample for now


> Javascript isn't produced correctly when beads are not the first element of View
> --------------------------------------------------------------------------------
>
>                 Key: FLEX-35206
>                 URL: https://issues.apache.org/jira/browse/FLEX-35206
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: FlexJS
>    Affects Versions: Apache FlexJS 0.7.0, Apache FlexJS 0.8.0
>            Reporter: Pan Li
>            Priority: Minor
>
> {code}
>     <js:View >
> 	<js:Container height="320" width="721" style="border:1px solid">
> 	</js:Container>
> 	<js:beads>
> 		<js:ViewDataBinding/>
> 	</js:beads>
>          <js:Label text="something"/>
> </js:View>
> {code}
> Above code doesn't report error when building to html/javascript, but when running it
doesn't show the label control.
> In awf mode it runs without problem.
> There could be other unexpected behavior when bead is not the top element and the UI
has more elements or files:
> Sometimes it build but when running it stop in javascript error. Sometimes it builds
but after the normal building process the SDK reports "javascript" building error. I could
not reproduce them with simple sample for now



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message