flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Mclean (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLEX-35165) Remove bundling of Apache 1.0 licensed software
Date Thu, 03 Nov 2016 06:38:58 GMT

    [ https://issues.apache.org/jira/browse/FLEX-35165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15631805#comment-15631805
] 

Justin Mclean edited comment on FLEX-35165 at 11/3/16 6:38 AM:
---------------------------------------------------------------

Looks like JServ was only using for testing so removing it was the simplest option. Once confirmed
by someone else we can close this issue.


was (Author: jmclean):
Looks like JServ was only using for testing so removing it was the simplest option.

> Remove bundling of Apache 1.0 licensed software
> -----------------------------------------------
>
>                 Key: FLEX-35165
>                 URL: https://issues.apache.org/jira/browse/FLEX-35165
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.15.0
>            Reporter: Justin Mclean
>            Priority: Blocker
>
> On legal discuss it was pointed out that the Apache 1.0 license [1] contains an advertising
clause which actually makes it Category X / incompatible with the Apache 1.1/2.0 licenses.
> The Flex SDK use code  from the Apache JServ project which is Apache 1.0 licensed. [2]

> 1. https://www.apache.org/licenses/LICENSE-1.0
> 2. https://github.com/apache/flex-sdk/blob/develop/modules/thirdparty/velocity/test/texen-classpath/jar-contents/license.txt



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message