flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mihai Chira (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLEX-33646) The "required" property on Validator should be a getter/setter
Date Tue, 02 Feb 2016 16:08:39 GMT

     [ https://issues.apache.org/jira/browse/FLEX-33646?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mihai Chira updated FLEX-33646:
-------------------------------
    Fix Version/s: Apache Flex 4.16.0

> The "required" property on Validator should be a getter/setter
> --------------------------------------------------------------
>
>                 Key: FLEX-33646
>                 URL: https://issues.apache.org/jira/browse/FLEX-33646
>             Project: Apache Flex
>          Issue Type: Improvement
>          Components: Validators
>    Affects Versions: Apache Flex 4.8 (parity release)
>            Reporter: Devin Holloway
>            Assignee: Mihai Chira
>            Priority: Minor
>             Fix For: Apache Flex 4.16.0
>
>
> My scenario is a CompositeValidator that can wrap multiple validators and treat them
as a single validator. Some properties can be set on the parent CompositeValidator which would
propagate down to the child validators. Since the "required" attribute is not a setter, and
it defaults to true, it's impossible to tell if the developer explicitly set it to true (which
would indicate it needs propagated) or if they simply omitted the property and let it default
to true.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message