flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andriy Panas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-34754) Spark VideoPlayer does not display video (only audio) since Flex SDK 4.11
Date Thu, 10 Sep 2015 11:23:46 GMT

    [ https://issues.apache.org/jira/browse/FLEX-34754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14738598#comment-14738598
] 

Andriy Panas commented on FLEX-34754:
-------------------------------------

Duplicate of https://issues.apache.org/jira/browse/FLEX-33856

>From OSMF documentation
"Similarly, in Flex applications, the video is not displayed unless you add backgroundAlpha="0"
to the Application container and to any other containers that could obscure the video"

http://help.adobe.com/en_US/OSMF/1.0/Dev/WSc6f922f643dd2e6d-5718733812f2bec460d-7fff.html

> Spark VideoPlayer does not display video (only audio) since Flex SDK 4.11
> -------------------------------------------------------------------------
>
>                 Key: FLEX-34754
>                 URL: https://issues.apache.org/jira/browse/FLEX-34754
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: Spark: VideoPlayer
>    Affects Versions: Apache Flex 4.11.0, Apache Flex 4.12.0, Apache Flex 4.13.0, Apache
Flex 4.12.1, Apache Flex 4.14.0
>            Reporter: David Reade
>            Priority: Blocker
>
> The Spark VideoPlayer/VideoDisplay components do not display video. Audio streams fine,
but where the video should be it's black/blank. The video duration is populated and the seek
bar moves and can be controlled but when seeking to another position, the video still does
not display but the audio can be heard.
> Switching to Flex SDK 4.10 or older immediately resolves the problem. This bug can be
replicated using Flex SDK 4.11, 4.12, 4.12.1, 4.13 and 4.14. All SDKs were downloaded using
the installer and Flash Player 16 and AIR 16 was selected for each SDK.
> The Flex project does not have any additional customisations.
> The video playback works as expected when using Flex SDK 4.10, 4.9.1, 4.9.0, 4.8.0 and
4.6.0.
> Could the OSMF update in Flex SDK 4.11 be the cause?
> Source code as follows:
> {code}
> <?xml version="1.0" encoding="utf-8"?>
> <s:WindowedApplication xmlns:fx="http://ns.adobe.com/mxml/2009" 
>                        xmlns:s="library://ns.adobe.com/flex/spark" 
>                        xmlns:mx="library://ns.adobe.com/flex/mx"
>                        creationComplete="maximize()">
>     <s:VideoPlayer source="rtmp://flash.oit.duke.edu/vod/MP4:test/brunswick.m4v"/>
> </s:WindowedApplication>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message