flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Harui (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-34922) Using FlexJs 0.0.2 with Flash Builder 4.6 , Unable to compile existing flex project om.adobe.flexbuilder.multisdk.compiler.internal.FlexLibraryBuilder
Date Fri, 31 Jul 2015 13:07:04 GMT

    [ https://issues.apache.org/jira/browse/FLEX-34922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14649195#comment-14649195
] 

Alex Harui commented on FLEX-34922:
-----------------------------------

Hi,

I noticed that the title of this issue says you are trying "to compile existing flex project".
 FlexJS isn't designed to compile the same APIs as the current Flex SDK.

Have you successfully compiled one of the examples that work for us?  See the instructions
here: https://cwiki.apache.org/confluence/display/FLEX/Using+FlexJS+with+Adobe+Flash+Builder
under "Creating a FlexJS Application".

The current FlexJS APIs are designed to be a simple abstraction over the browser APIs so we
can prove it works, see how it performs and make it easier to debug.  I hope to see folks
create a more Spark and MX compatible API set someday, but I doubt it will get to 100% compatibility.
 It is better to have you do some migration to get better performance.  Some Flash APIs will
be hard or non-performant to emulate in the browser.  See https://cwiki.apache.org/confluence/display/FLEX/Alex%27s+FlexJS+Prototype


> Using FlexJs 0.0.2 with Flash Builder 4.6 , Unable to compile existing flex project om.adobe.flexbuilder.multisdk.compiler.internal.FlexLibraryBuilder
> ------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: FLEX-34922
>                 URL: https://issues.apache.org/jira/browse/FLEX-34922
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: FlexJS
>    Affects Versions: Apache FlexJS 0.0.2
>         Environment: Flash Builder 4.6
>            Reporter: Kartikey
>
> java.lang.NoSuchMethodError: com.adobe.flexbuilder.multisdk.compiler.internal.FlexLibraryBuilder$MyLibrary.link(Ljava/io/OutputStream;)J
> 	at com.adobe.flexbuilder.multisdk.compiler.internal.FlexLibraryBuilder$MyLibrary.mybuild(FlexLibraryBuilder.java:334)
> 	at com.adobe.flexbuilder.multisdk.compiler.internal.FlexLibraryBuilder.build(FlexLibraryBuilder.java:131)
> 	at com.adobe.flexbuilder.multisdk.compiler.internal.ASBuilder.build(ASBuilder.java:198)
> 	at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.buildItem(FlexProjectBuilder.java:607)
> 	at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.build(FlexProjectBuilder.java:377)
> 	at com.adobe.flexbuilder.project.compiler.internal.FlexIncrementalBuilder.build(FlexIncrementalBuilder.java:187)
> 	at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
> 	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> 	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
> 	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
> 	at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
> 	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> 	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
> 	at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
> 	at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
> 	at org.eclipse.core.internal.resources.Workspace.buildInternal(Workspace.java:513)
> 	at org.eclipse.core.internal.resources.Workspace.build(Workspace.java:432)
> 	at org.eclipse.ui.actions.BuildAction$1.runInWorkspace(BuildAction.java:305)
> 	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
> 	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message