flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Bierman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-34849) adding flex-messaging-core as a maven dependency gives a wrong dependency
Date Tue, 26 May 2015 02:08:17 GMT

    [ https://issues.apache.org/jira/browse/FLEX-34849?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14558615#comment-14558615
] 

Peter Bierman commented on FLEX-34849:
--------------------------------------

Hi Christofer, thank you for looking into this problem.
My current setup is an eclipse luna (4.4.2) workspace on a windows 8.1 machine.
I have a environment variable for JAVA_HOME pointing to:
JAVA_HOME=C:\Program Files\Java\jdk1.8.0_45

java - version gives the following result 
java version "1.8.0_45"
Java(TM) SE Runtime Environment (build 1.8.0_45-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

Displaying the java.home variable through the maven script with the help of the link you send
me yields the following result:
 [echo] [java.home] C:\Program Files\Java\jdk1.8.0_45\jre
So that seems to be ok, but that is when running from the CLI.

If I run directly from eclipse I get the following result:
   [echo] [java.home] C:\Program Files\Java\jre1.8.0_45

So eclipse is pointing to the JRE and not JDK even though my JAVA_HOME is set to the JDK.
So I believe you are correct in assuming that is a local setup problem.
Changing the project settings to the java jdk unfortunately doesn't help it seems (even though
I get a correct path in the mvn command)

I still get the message within eclipse, but I'm confident it's a local setup problem, I'll
try some different things and see if I can get the message to disappear locally, if I do I
will add another comment.
But as already mentioned it's not a big problem (just a minor nuisance for me), because I
can compile on the command line so don't spend too much time on this.


> adding flex-messaging-core as a maven dependency gives a wrong dependency 
> --------------------------------------------------------------------------
>
>                 Key: FLEX-34849
>                 URL: https://issues.apache.org/jira/browse/FLEX-34849
>             Project: Apache Flex
>          Issue Type: Dependency upgrade
>          Components: BlazeDS
>    Affects Versions: BlazeDS 4.7
>         Environment: eclipse luna, maven 3.3
>            Reporter: Peter Bierman
>            Priority: Minor
>
> When adding this dependency to my pom.xml inside elipse luna building a project which
includes blazeds:
> 	<dependency>
> 		<groupId>org.apache.flex.blazeds</groupId>
> 		<artifactId>flex-messaging-common</artifactId>
> 		<version>4.7.0</version>
> 	</dependency>
> gives the following error:
> Description	Resource	Path	Location	Type
> Missing artifact com.sun:tools:jar:jdk-version	pom.xml Maven Dependency Problem
> now the tools.jar is automaticcaly added through the jdk but it seems somewhere in the
dependency list the text 'jdk-version' is still present instead of the real version number
like 1.6, 1.7 or 1.8.
> I'm no maven expert but probably somewhere there are some missing curly brackets ({jdk-version})
or something which makes the text hard coded instead of evaluated.
> as a workaround I added the tools.jar to my local repository through the following command
(from inside my jdk lib folder):
> c:\Program Files\Java\jdk1.8.0_45\lib>mvn install:install-file -DgroupId=com.sun
>  -DartifactId=tools -Dpackaging=jar -Dversion=jdk-version -Dfile=tools.jar -Dgen
> eratePom=true



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message