flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-34754) Spark VideoPlayer does not display video (only audio) since Flex SDK 4.11
Date Fri, 27 Mar 2015 12:11:53 GMT

    [ https://issues.apache.org/jira/browse/FLEX-34754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14383739#comment-14383739
] 

Fred commented on FLEX-34754:
-----------------------------

I 'am confirming this issue.
One workaround is to use old version of osmf.swf. This is working great for me.

I had copy :
sdks\4.6.0\frameworks\libs\osmf.swf  to sdks\4.14.0\frameworks\libs\osmf.swf  

and 
\sdks\4.6.0\frameworks\projects\osmf dir to sdks\4.14.0\frameworks\projects\osmf

Regards




> Spark VideoPlayer does not display video (only audio) since Flex SDK 4.11
> -------------------------------------------------------------------------
>
>                 Key: FLEX-34754
>                 URL: https://issues.apache.org/jira/browse/FLEX-34754
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: Spark: VideoPlayer
>    Affects Versions: Apache Flex 4.11.0, Apache Flex 4.12.0, Apache Flex 4.13.0, Apache
Flex 4.12.1, Apache Flex 4.14.0
>            Reporter: David Reade
>            Priority: Blocker
>
> The Spark VideoPlayer/VideoDisplay components do not display video. Audio streams fine,
but where the video should be it's black/blank. The video duration is populated and the seek
bar moves and can be controlled but when seeking to another position, the video still does
not display but the audio can be heard.
> Switching to Flex SDK 4.10 or older immediately resolves the problem. This bug can be
replicated using Flex SDK 4.11, 4.12, 4.12.1, 4.13 and 4.14. All SDKs were downloaded using
the installer and Flash Player 16 and AIR 16 was selected for each SDK.
> The Flex project does not have any additional customisations.
> The video playback works as expected when using Flex SDK 4.10, 4.9.1, 4.9.0, 4.8.0 and
4.6.0.
> Could the OSMF update in Flex SDK 4.11 be the cause?
> Source code as follows:
> {code}
> <?xml version="1.0" encoding="utf-8"?>
> <s:WindowedApplication xmlns:fx="http://ns.adobe.com/mxml/2009" 
>                        xmlns:s="library://ns.adobe.com/flex/spark" 
>                        xmlns:mx="library://ns.adobe.com/flex/mx"
>                        creationComplete="maximize()">
>     <s:VideoPlayer source="rtmp://flash.oit.duke.edu/vod/MP4:test/brunswick.m4v"/>
> </s:WindowedApplication>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message