flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Turner (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLEX-34735) Spark CurrencyFormatter incorrectly formats 0 on iPad
Date Wed, 04 Feb 2015 18:10:34 GMT
Bill Turner created FLEX-34735:
----------------------------------

             Summary: Spark CurrencyFormatter incorrectly formats 0 on iPad
                 Key: FLEX-34735
                 URL: https://issues.apache.org/jira/browse/FLEX-34735
             Project: Apache Flex
          Issue Type: Bug
          Components: Spark: Formatters
    Affects Versions: Apache Flex 4.13.0
         Environment: iOS 8.1.3
            Reporter: Bill Turner


Formatting a zero currency value with spark.formatters.CurrencyFormatter and the en_US locale
works correctly on all platforms I've tried but not on iPad - instead of 0.00 it returns 0
(no decimals).  Other number values without fractional parts format correctly (i.e., 78.00)

I've tried forcing fractionalDigits=2 and trailingZeros=true, no change.

This actually is an issue with flash.globalization.CurrencyFormatter - I traced through the
code and the Spark formatter is just returning the result from the lower-level formatter.
 I tried to submit a bug with Adobe, but was not successful.

[The MX CurrencyFormatter works correctly, but I'd rather not roll back...]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message