flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rustam Abdullaev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-27596) No backwards compatibility when using the Embed Directive
Date Tue, 17 Feb 2015 16:44:12 GMT

    [ https://issues.apache.org/jira/browse/FLEX-27596?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14324427#comment-14324427
] 

Rustam Abdullaev commented on FLEX-27596:
-----------------------------------------

Please fix this!!
Even if compiled with target player 10.0, the produced swf still won't run in 10.0. It runs
fine only in 10.1.
We really need the swf to run in 10.0.
Adobe Flex SDK 4.6 worked fine (although in FD4 it must be the default SDK, simply selecting
it per project doesn't solve the issue).

> No backwards compatibility when using the Embed Directive
> ---------------------------------------------------------
>
>                 Key: FLEX-27596
>                 URL: https://issues.apache.org/jira/browse/FLEX-27596
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: Embedded Asset Transcoding
>    Affects Versions: Adobe Flex SDK 4.5 (Release)
>         Environment: Affected OS(s): All OS Platforms
> Affected OS(s): All OS Platforms
> Language Found: English
>            Reporter: Adobe JIRA
>
> Steps to reproduce:
> 1.  Start a new AS3 project in Flash Builder 4.5.  Simply embed a JPG using the embed
directive
> package
> {
> 	import flash.display.Sprite;
> 	
> 	public class TestEmbed extends Sprite
> 	{
> 		[Embed(source="myimage.jpg")]
> 		public var myGraphic:Class;
> 		public function TestEmbed(){}
> 	}
> }
> 2. Compile and test project (works fine)
> 3. Load SWF with Flash Player 10.0
>  
>  Actual Results:
> Runtime error:
> VerifyError: Error #1053: Illegal override of z in mx.core.BitmapAsset. 
> Assets won't be available for use, and in my project, Flash did not continue onto the
constructor of the main application class.
> If embedding assets/symbols from SWF, there will be the same error, but the problem will
be with mx.core.SpriteAsset.
> I put the 10.2 playerglobal into the Flex 3.5 SDK and got the same results - so it might
be a problem with the playerglobal.swc API
>  
>  Expected Results:
>  No runtime error and assets are available for use
>  
>  Workaround (if any):
>  I couldn't figure anything out - and it meant that I couldn't upgrade my SDK to 4.5
for the project and still remain backwards compatible for my customers



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message