flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Martin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLEX-34054) Formatting applied to NumericStepper when using increment/decrement arrows
Date Wed, 22 Jan 2014 20:57:32 GMT

     [ https://issues.apache.org/jira/browse/FLEX-34054?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Martin updated FLEX-34054:
--------------------------------

    Description: 
When a user uses the increment and decrement button on the spark numeric stepper formatting
is now being applied to the value that is being displayed.  This is new behavior since 4.9.1

Steps to Reproduce

1.) Open and run the attached project
2.) In the top most numericstepper, click on the increment button.

Result

The string is formatted (for US it's 1,001)

Expected Result

The string is not formatted

Workaround

In the provided project I've included a workaround.  Users can set a valueFormatFunction to
enforce whatever format they'd like.

Extra Notes

I've included images of the varying formatting between 4.9.1, 4.10.0, and 4.11.0.  It would
seem that there have been fixes regarding formatting that maybe cause this one to creep up.
 Will attach the necessary files shortly


  was:
When a user uses the increment and decrement button on the spark numeric stepper formatting
is now being applied to the value that is being displayed resulting in incorrect highlighting
of the text.  This is new behavior since 4.9.1

Steps to Reproduce

1.) Open and run the attached project
2.) In the top most numericstepper, click on the increment button.

Result

The string is formatted (for US it's 1,001) and the highlighting is off.  It only highlights
the first four characters

Expected Result

The string is not formatted and all four characters are highlighted

Workaround

In the provided project I've included a workaround.  Users can set a valueFormatFunction to
enforce whatever format they'd like.

Extra Notes

I've included images of the varying formatting between 4.9.1, 4.10.0, and 4.11.0.  It would
seem that there have been fixes regarding formatting that maybe cause this one to creep up.
 Will attach the necessary files shortly


        Summary: Formatting applied to NumericStepper when using increment/decrement arrows
 (was: Formatting applied to NumericStepper when using inc/dec arrows and incorrect highlighting)

So I did a little more testing today as the whole highlighting thing bugged me.  Turns out
that even in Flex 4.6 that is the normal highlighting behavior.

So really this is just for the new addition of text formatting being applied when using the
increment and decrement buttons.  I updated the ticket to reflect this.

> Formatting applied to NumericStepper when using increment/decrement arrows
> --------------------------------------------------------------------------
>
>                 Key: FLEX-34054
>                 URL: https://issues.apache.org/jira/browse/FLEX-34054
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: Spark: NumericStepper
>    Affects Versions: Apache Flex 4.11.0
>            Reporter: Chris Martin
>              Labels: easytest
>         Attachments: NumericStepper Flex4_10_0.png, NumericStepper Flex4_11_0.png, NumericStepper
Flex4_9_1.png, NumericStepperFormatting.zip
>
>
> When a user uses the increment and decrement button on the spark numeric stepper formatting
is now being applied to the value that is being displayed.  This is new behavior since 4.9.1
> Steps to Reproduce
> 1.) Open and run the attached project
> 2.) In the top most numericstepper, click on the increment button.
> Result
> The string is formatted (for US it's 1,001)
> Expected Result
> The string is not formatted
> Workaround
> In the provided project I've included a workaround.  Users can set a valueFormatFunction
to enforce whatever format they'd like.
> Extra Notes
> I've included images of the varying formatting between 4.9.1, 4.10.0, and 4.11.0.  It
would seem that there have been fixes regarding formatting that maybe cause this one to creep
up.  Will attach the necessary files shortly



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message