flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Kessler (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (FLEX-33919) Listbase selectItem getter does not validate selectedIndex for values below 0 other than -1.
Date Wed, 20 Nov 2013 02:18:17 GMT

     [ https://issues.apache.org/jira/browse/FLEX-33919?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mark Kessler resolved FLEX-33919.
---------------------------------

       Resolution: Fixed
    Fix Version/s: Apache Flex 4.12.0

Corrected the range check to included everything below zero.

sdk compiled successfully.
ran minirun mustella test successfully.



> Listbase selectItem getter does not validate selectedIndex for values below 0 other than
-1.  
> ----------------------------------------------------------------------------------------------
>
>                 Key: FLEX-33919
>                 URL: https://issues.apache.org/jira/browse/FLEX-33919
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.11.0
>            Reporter: Mark Kessler
>            Assignee: Mark Kessler
>            Priority: Minor
>             Fix For: Apache Flex 4.12.0
>
>
> Listbase selectItem getter does not validate selectedIndex for values below 0 other than
-1.  
> Able to cause an out of range error when it attempts to dataProvider.getItemAt(selectedIndex)
using negative numbers



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message