flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Harui (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-33876) Font Styles not taking effect on mx:PieCharts, mx:ColumnCharts, mx:Legends, s:Form and s:Alert
Date Wed, 13 Nov 2013 06:56:19 GMT

    [ https://issues.apache.org/jira/browse/FLEX-33876?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13821010#comment-13821010
] 

Alex Harui commented on FLEX-33876:
-----------------------------------

By default, Charts use Spark Labels.  Not sure when we made the switch.  There is a file called
MXCharts.css (in frameworks/projects/charts/src that you can include in the app to switch
back to mx:Label if that's what you want.  Otherwise, yes, you have to embed both fonts or
get rid of all TextFields in the app.

I also noted that some fonts appear to be bold and no bold font is embedded which may also
appear to make that embedding isn't working.

> Font Styles not taking effect on mx:PieCharts, mx:ColumnCharts, mx:Legends, s:Form and
s:Alert
> ----------------------------------------------------------------------------------------------
>
>                 Key: FLEX-33876
>                 URL: https://issues.apache.org/jira/browse/FLEX-33876
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.9.0, Apache Flex 4.10.0, Apache Flex 4.11.0
>         Environment: Windows 7 Professional SP1 64Bit running on MacBook Pro (mid 2010)
OSX 10.9 Bootcamp.
> Apache Flex SDK 4.11 running on FlashBuilder 4.7 Standard.
>            Reporter: Dylan Randall
>            Priority: Critical
>         Attachments: FontStyleTest.fxp, SofiaProLight.otf
>
>
> When I try to apply a css style that lives in the main application onto a sub application
loaded into the main application via a SWFLoader some styles are not set. Instances like s:Label
have the style applied however mx:PieChart, mx:ColumnChart and mx:Legend the style is not
applied. I am only trying to apply a font to the text of these components. Things like the
callouts and the text on the legends do not get the style applied to them. The same goes for
s:Form the font style isn't applied to the component. The same font style is also not being
applied to the title string of the s:Alert component but the body or message string the font
is being applied correctly.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message