flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Mclean (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLEX-33781) Flex4 mxml data binding "public" issue
Date Thu, 26 Sep 2013 07:52:15 GMT

    [ https://issues.apache.org/jira/browse/FLEX-33781?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13778559#comment-13778559
] 

Justin Mclean edited comment on FLEX-33781 at 9/26/13 7:52 AM:
---------------------------------------------------------------

This example has the same issue with Adobe Flex 4.6 but not Adobe Flex 3.6A so it not unique
to Apache Flex but is an Adobe Flex 3 vs 4 issue.

                
      was (Author: jmclean):
    This example has the same issue with Adobe Flex 4.6 but not Adobe Flex 3.6A so it not
unique to Apache Flex but an Adobe Flex 3 vs 4 issue.

                  
> Flex4 mxml data binding "public" issue
> --------------------------------------
>
>                 Key: FLEX-33781
>                 URL: https://issues.apache.org/jira/browse/FLEX-33781
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.10.0
>         Environment: windows XP, flex builder 4
>            Reporter: sky
>              Labels: Flex4, binding, data
>             Fix For: Apache Flex 4.10.0
>
>   Original Estimate: 96h
>  Remaining Estimate: 96h
>
> I'm using flex builder4, then i wrote a mxml sample, but it can't compile successfully.
> MXML:
> <?xml version="1.0" encoding="utf-8"?>
> <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">
> 	<mx:Script source="test.as"/>
> 	<mx:ControlBar id="ctlbar" horizontalAlign="right" width="100%"
> 				   paddingRight="{maxFontSize}" paddingTop="0" paddingBottom="0">
> 		<mx:Button id="cancelBtn" label="Cancel" minWidth="11"/>
> 	</mx:ControlBar>
> </mx:Application>
> test.as:
> [Bindable]
> public var maxFontSize:Number = 115;
> I want to use "maxFontSize" as data binding, but it can't compile properly if i use flex
sdk4.10, but if i use flex sdk3.5, it will compile successfully. Also if i change "public"
to "internal", it will compile successfully even though use sdk4.10. But why this happened?
Who knows that? Thanks.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message